SOLVED WordPress Toolkit Repo Connection Issue?

schoeps

Well-Known Member
Sep 22, 2004
114
10
168
For some reason, I cannot download and add WordPress toolkit and the inability to connect to the repo is not allowing updates to run. Is the repo down? Change IP? Anyone else having this issue?

When Installing:
Error: There was a problem with the install. Refresh the page and try again.: [object MessageEvent]

When Updating:
System update process has started.

“/usr/bin/yum” reported error code “1” when it ended: w/ /usr/bin/yum upgrade -y
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
* EA4: 63.247.64.58
* cpanel-addons-production-feed: 63.247.64.58
* cpanel-plugins: 63.247.64.58
* base: download.cf.centos.org
* epel: d2lzkl7pfhq30w.cloudfront.net
* extras: download.cf.centos.org
* updates: download.cf.centos.org
https://wp-toolkit.plesk.com/cPanel/build-5.9.1/wp-toolkit/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article


If above article doesn't help to resolve this issue please use My View - CentOS Bug Tracker.



One of the configured repositories failed (WordPress Toolkit for cPanel),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=wp-toolkit-cpanel ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable wp-toolkit-cpanel
or
subscription-manager repos --disable=wp-toolkit-cpanel

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=wp-toolkit-cpanel.skip_if_unavailable=true

failure: repodata/repomd.xml from wp-toolkit-cpanel: [Errno 256] No more mirrors to try.
https://wp-toolkit.plesk.com/cPanel/build-5.9.1/wp-toolkit/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

Often errors like this can be resolved by running `yum makecache`

System update process has finished.


I can just disable it, didnt know if anyone had a similar issue...
 
Last edited by a moderator:

rbairwell

Well-Known Member
May 28, 2022
96
40
18
Mansfield, Nottingham, UK
cPanel Access Level
Root Administrator
Hi,

Which version of Wordpress toolkit have you got installed?
`rpm -qa|grep wp-toolkit`
should show the version (according to https://support.cpanel.net/hc/en-us/articles/1500000253161-Updating-WordPress-Toolkit ). I've currently got:
wp-toolkit-cpanel-5.12.3-6612.x86_64
on my CentOS server. The mention of the 5.9.1 URL makes me think you have a reasonably out of date version.

I would try to see if you can update it ( see WordPress Toolkit | cPanel & WHM Documentation ) and if that still gives you problems, I would try uninstalling and reinstalling the toolkit (as detailed on that page).
 

schoeps

Well-Known Member
Sep 22, 2004
114
10
168
Rex helped me wit this this morning, it was an artifct from installing and deleting WordPress Toolkit. The fix was to replace the contents of

/etc/yum.repos.d/wp-toolkit-cpanel.repo

with the following:
[wp-toolkit-cpanel]
name=WordPress Toolkit for cPanel
baseurl=https://wp-toolkit.plesk.com/cPanel/CentOS-7-x86_64/latest/wp-toolkit/
enabled=1
gpgcheck=1

[wp-toolkit-thirdparties]
name=WordPress Toolkit third parties
baseurl=https://wp-toolkit.plesk.com/cPanel/CentOS-7-x86_64/latest/thirdparty/
enabled=1
gpgcheck=1