The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Working with Email Service Providers

Discussion in 'E-mail Discussions' started by crwilliams, Apr 23, 2006.

  1. crwilliams

    crwilliams Well-Known Member

    Joined:
    Sep 10, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Sorry to bother everyone with what's likely a dumb question, but I couldn't find the answer on my own.

    I have a customer who wants to use a mail service provider. The mail host has given the customer the name to use in the MX record. The provider says that that one simple change to the MX record is all that is needed, and left it at that.

    Is it really that simple? Is it possible that this will work without being given an IP, and no additional changes, such as with an A record? Is this what would have been done if the customer had entered the mail provider's cluster name in her cpanel, rather than asking us to do it?

    Also... the customer is under the impression from the mail host that her mail should begin routing to her new service right away. I made the MX change in the DNS record several hours ago, but she's saying her mail provider is telling her that it's not active yet.

    One last question, and this one is probably a dumb one, too (sorry). Our MX records all end with a period after the server name it's pointing to (such as domain.com. rather than domain.com). The mail provider didn't indicate this. Is this a protocol that's obviously over my head? Should I reset the DNS record again to include it, or leave it as the mail provider indicated, without the ending period?

    Thanks much for any insights!
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    In order for your server to route mail to an external mail server, the domain name in question would need to be removed from /etc/localdomains and added to /etc/remotedomains.

    I believe that this should be performed automatically if you use the "Edit MX Entry" option in WHM, but would not be performed if you just editted the DNS zone directly.
     
  3. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    Also, the trailing period on the record IS supposed to be there, and can cause issues if it's not.

    And since you're making changes to DNS, it could take several hours to a couple of days to propogate throughout the net.
     
  4. crwilliams

    crwilliams Well-Known Member

    Joined:
    Sep 10, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Thanks, guys!

    Adding the trailing period turned out to be all I needed to do. Once that was done, it was only a couple hours before the customer's mail began routing properly to her service. I didn't have to make any changes to the localdomains or remotedomains files, by the way, and the change to the MX record in the WHM didn't make any of those changes either. Curious...

    But at least now I know that it really is that simple when a client wants to route mail off-network to a service that only gives a server/cluster name without supplying an IP.

    Thanks again!
     
  5. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    If you didn't remove the customer domain from /etc/localdomains, and put it into /etc/remotedomains you'll find that email to her from her server will go into her local account, rather than going to the MX destination. Even if you get away with it working without the localdomains change, you should still make the change to document what's going on in the future (and I have no idea why it would work without the change either).
     
Loading...

Share This Page