Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WP-Cron Not Running Properly

Discussion in 'General Discussion' started by Patrik, Apr 5, 2018.

  1. Patrik

    Patrik Member

    Joined:
    Aug 25, 2017
    Messages:
    18
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator
    The WP-Cron on my customers sites are not running. WP Crontrol gives me this error message:

    There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    cURL error 28: Connection timed out after 3001 milliseconds


    None of the WP-Cron jobs have run since March 20th. Kind of terrible since they aren't receiving updates to WordPress or its plugins. I'm not sure what happened on this day or the day before, but it could be after I ran the latest update to cPanel and restarted the server.

    I saw something about using OpenDNS servers for resolving instead of Google's 8.8.8.8. So I changed it to OpenDNS on the off-chance that it'd work, but it didn't.

    Does anyone know how to fix this?
     
    #1 Patrik, Apr 5, 2018
    Last edited: Apr 5, 2018
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    372
    Likes Received:
    21
    Trophy Points:
    93
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Patrik

    This does sound like a resolver issue. You may want to contact your provider to assist you with this further. Some providers require that you use their resolvers. If your provider is unable to provide a resolution for this you are welcome to open a ticket with us using the link in my signature, ultimately though this issue is best suited for a system administrator. If you don't have one you might check here:

    System Administration Services | cPanel Forums

    Thank you,
     
  3. Patrik

    Patrik Member

    Joined:
    Aug 25, 2017
    Messages:
    18
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator
    Is there a way to determine what it's trying to resolve? Since other servers on this c-net is using OpenDNS successfully, I don't see why this one couldn't. I'm wondering if it's trying to resolve itself and for some reason it can't. It would then not be a resolver issue, but a config issue.

    I know, it's a stretch, but I'm kind of struggling here.
     
  4. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    372
    Likes Received:
    21
    Trophy Points:
    93
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Patrik

    You could be right that it's not able to resolve/connect to itself especially if you're not experiencing DNS resolution issues with other sites, though when I search this specific issue all articles refer to the resolvers. When you updated them did you also restart named? Or has it restarted since? Can you tell me the precise steps you took to update the DNS resolvers?


    Thank you,
     
  5. Patrik

    Patrik Member

    Joined:
    Aug 25, 2017
    Messages:
    18
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator
    I merely changed the resolvers in /etc/resolv.conf and have since then rebooted the server. However I NOW discover that it changed it back somehow. So I went through the WHM panel and changed it there instead. Afterwards, I rebooted the machine. And for some reason, it is changed back to 8.8.8.8 again!

    [root@... ~]# cat /etc/resolv.conf
    # Generated by NetworkManager
    search *****************
    nameserver 8.8.8.8

    Now I'm seriously confused.
     
  6. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    372
    Likes Received:
    21
    Trophy Points:
    93
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Patrik

    That's happening because you're using Network Manager, it's auto-generating the conf file. We don't support Network Manager because it can interfere with the ipaliases service and we have instructions on how to disable it here: How to Disable Network Manager

    To avoid this from occurring again I would suggest disabling network manager then updating the resolv.conf file once more. Keep in mind that it does require a network restart and you might want to wait until off-peak time to restart though it shouldn't take more than a couple seconds to restart (just in case there are unforeseen issues)


    Thank you,
     
  7. Patrik

    Patrik Member

    Joined:
    Aug 25, 2017
    Messages:
    18
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator
    Hey.

    Ok so I made a mistake in the installation of the server. I corrected it now and the resolver IPs stick after a reboot. However it did not solve the issue. I still get that pesky cURL error 28.
     
  8. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    372
    Likes Received:
    21
    Trophy Points:
    93
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Patrik I'm sorry to hear that, please open a ticket using the link in my signature so we can take a closer look
     
Loading...

Share This Page