wp-includes: no matching DirectoryIndex

dermotd

Member
Nov 26, 2019
13
0
1
Dublin
cPanel Access Level
Root Administrator
In reviewing my /var/log/apache2/error_log file, I see daily error messages for:
Code:
[Fri Dec 13 11:33:31.437413 2019] [autoindex:error] [pid 84601] [client x.x.x.x:42504] AH01276: Cannot serve directory /home/client/public_html/wp-includes/css/: No matching DirectoryIndex (index.php,index.php5,index.php4,index.php3,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.jp,index.phtml,index.shtml,index.xhtml,index.html,index.htm,index.wml,Default.html,Default.htm,default.html,default.htm,home.html,home.htm,index.js) found, and server-generated directory index forbidden by Options directive
Following advice from another thread in this forum, I have been creating blank index.html files in the wp-includes/css/ directories, but with ~60 clients on the server I am wondering if there is not a more efficient way of doing this, and resolving this issue?

Also, is there any impact to creating a blank (0 bytes) index.html file in the wp-includes/css and wp-content/themes/[active-theme-name]/ directories?
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,755
316
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Actually, disregard, if you are getting that error you should already have indexes disabled.

The error in the log is no big deal and can be ignored, I would not go to the trouble of creating blank index files.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston