The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrong page title on cPanel - CloudFlare Issue

Discussion in 'General Discussion' started by KREATOR, Nov 30, 2015.

  1. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hello,

    I recently installed the CloudFlare plugin for CPanel and noticed that some of the page titles and headers are wrong.

    When I click on Email Accounts I get page title 'CPanel - CloudFlare' and 'CloudFlare' as the page header. When I click on 'Forwarders' I get page title 'CPanel - CloudFlare Status' and 'CloudFlare Status' as page header. When I actually click on the CloudFlare icon I get page title 'Cpanel - ' and a blank page header. You can see the attached images for more details.

    How can I fix this?
    Thanks.
     

    Attached Files:

  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Certainly odd, to be sure. Have you tried forcing a cPanel Update to the server? I have CloudFlare running here and do not see the issue on this end.
     
  3. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I have just tried forcing cPanel update but still the same. The problem is only in paper_lantern theme because I checked on x3 and it's all correct. I see that the order on both themes are different though. On x3 the CloudFlare section is placed third after Domains, on paper_lantern it's placed fifth after Email section.
     
  4. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Anyone? I haven't found a solution for this yet, problem is with paper lantern theme only.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    None of your images actually show the problem. Those are all normal pages. If I'm missing something there, point to it for me please.
     
  6. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    1st image: Email Accounts page with "CloudFlare" header.
    2nd image: Forwarders page with "CloudFlare Status" header
    3rd image: Actual CloudFlare page with blank header, the header that is currently in Email Accounts page should be in this image.

    I'm now attaching a 4th image with "Addon Domains" page showing Email Accounts as title. So basically all pages' titles are mixed up starting from the Domains section.
     

    Attached Files:

  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks. Have you contacted CloudFlare about this?
     
  8. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Yes, similar answer that they do not see this issue on their end. Is there any way to rebuild the titles or something? I even tried uninstalling and reinstalling the CloudFlare plugin but still the same.
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    When you uninstalled, did the issue go away?

    Forcing a cPanel update to your system should check to make sure Paper Lantern is in working order.
     
  10. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    When I uninstalled the plugin the issue stayed the same. I also tried '/scripts/upcp --force' and still the same (cleared cache on my web browser of course).
     
  11. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You're not using a customized version of Paper Lantern either, correct?

    Please free to open a ticket to cPanel Technical Support about this and have them come by for a closer look. If you don't mind please post the ticket ID here in this thread.
     
  12. smurf

    smurf Member

    Joined:
    Jun 4, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    We're experiencing this exact issue as well. Did you find a fix?
     
  13. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you verify which version of cPanel is installed on your system?

    Thank you.
     
  14. KREATOR

    KREATOR Member

    Joined:
    Oct 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I opened a ticket and cPanel support team fixed it for me.
     
  15. smurf

    smurf Member

    Joined:
    Jun 4, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi Michael. We're currently using 11.52.2 (build 2)

    We've found the missing/incorrect icon issue only appears if there is a section missing, e.g the last feature, example phpMyAdmin has been disabled in Feature Manager leaving cPanel to hide the Databases category.

    The page source shows the missing details:

    HTML:
    <h1 class="page-header">
      <span id="icon-" class="page-icon icon-"></span>
      <span id="pageHeading"></span>
    </h1>
    
    The icons & titles work correctly if all features are enabled and every section is shown in the user's cPanel.

    Did the support team provide any details of the fix? We contacted cPanel support yesterday but we're still trying to get them to understand/reproduce the issue. Any references would be great :)
     
  16. smurf

    smurf Member

    Joined:
    Jun 4, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Quick update for anyone else who runs into the issue with page headings in Paper Lantern and reads this thread.

    cPanel support confirmed the bug and patched it in releases:

    11.54.0.2
    11.52.3.0
     
  17. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    To update, internal case PH-2024 was released to address an issue where, when certain features were disabled in the Feature Manager, Paper Lantern was showing the wrong title and icon on the page when clicking a feature in cPanel.

    Thank you.
     
Loading...

Share This Page