The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrong timestamp shown in Visitor

Discussion in 'General Discussion' started by Osama Tariq, Aug 23, 2016.

  1. Osama Tariq

    Osama Tariq Well-Known Member

    Joined:
    Nov 27, 2014
    Messages:
    187
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Lahore, Pakistan
    cPanel Access Level:
    Root Administrator
    Twitter:
    There's a bug found in visitor option in cpanel it shown wrong timestamp as i have check there's a right time shown in domlogs from commandline:

    Code:
    62.210.187.247 182.176.116.195 - - [23/Aug/2016:17:46:01 +0500] "GET /category/virtualization/ HTTP/1.1" 200 11716 "http://example.com/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0"
    Moreover i have restarted httpd and mysql services as well and there's correct time in whm and global php.ini

    Please find attachment with wrong timestamp.
     

    Attached Files:

    #1 Osama Tariq, Aug 23, 2016
    Last edited by a moderator: Aug 26, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,696
    Likes Received:
    656
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I've been unable to reproduce this issue on a test server. Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. Osama Tariq

    Osama Tariq Well-Known Member

    Joined:
    Nov 27, 2014
    Messages:
    187
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Lahore, Pakistan
    cPanel Access Level:
    Root Administrator
    Twitter:
    Isn't possible to investigate the issue without opening the ticket ?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,696
    Likes Received:
    656
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I've been unable to reproduce the issue, as when I test this the correct date/time appears in "cPanel >> Vistors". Opening a support ticket will allow us to take a closer look at your system to determine why this is happening.

    Thank you.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    194
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    The date 1/1/70 is "epoch date"
    en.wikipedia.org/wiki/Unix_time#History

    Something else going on there.
     
  6. xprt5

    xprt5 Well-Known Member

    Joined:
    Apr 6, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Houston
    Look at your domlogs file and you will see it lists two IP's in the front of each line and should only be one, the visitors.

    Check your LogFormat settings in Apache and you will find it set incorrectly.

    Should look like this with %a %l %u %t

    <IfModule mod_log_config.c>
    LogFormat "%a %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%a %l %u %t \"%r\" %>s %b" common

    Your LogFormat is incorrect and causing latest visitors date/time to show incorrectly as it reads entries from the domlogs file by "spaces" and the extra local IP is throwing off the format.

    Edit httpd.conf with above and restart apache then check latest visitors again.
     
  7. xprt5

    xprt5 Well-Known Member

    Joined:
    Apr 6, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Houston
    Also, you will need to manually edit the domlog files removing the 2nd local IP addresess, a quick sed search/replace will do this and new entries will be added correctly via Apache.
     
Loading...

Share This Page