wrong version of zend installed when using php4.4.x

kphelps

Registered
PartnerNOC
Sep 20, 2007
1
0
51
I noticed after installing zend optimizer via easyapache that it installs version 3.3.0 unless you are using php 4.4.x.

In this instance it actually installs zend optimizer 3.2.2:

# strings /usr/local/Zend/lib/Optimizer_TS-3.3.0/php-4.4.x/ZendOptimizer.so
...
...
VERSION=OPTIMIZER_3_2_2_RC5_20061225


I checked the tarball that is used via /scripts/installzendopt and downloaded a freshcopy and manually checked the file in there and it also shows 3_2_2.

Is there a reason for this or does the package need to be updated on cpanel's servers?
 

s.a.

Active Member
PartnerNOC
Aug 16, 2007
35
0
56
Toronto, Canada
There's an issue with php 4.4.8 and zend optimizer 3.3.0. php segfaults when you try to use remote includes. That's why cPanel installs zend 3.2.2.