The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrong web site opens with https://

Discussion in 'General Discussion' started by maxic9, Jan 29, 2013.

  1. maxic9

    maxic9 Registered

    Joined:
    Nov 7, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have a web site on my cPanel hosting with installed SSL certificate.
    This site is opened even if I open https://my.main.ip.address/
    Now I added another account in WHM that using the same IP address.
    When I am opening https://my.new.site I am getting my.old.ssl.site instead :(
    Is it possible to configure somehow, that https://my.new.site returns at least an error (while still work with with http://) or better return the correct site content?

    thanks!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You will need to assign a dedicated IP address to the account with the SSL certificate. Otherwise, any other account assigned to the shared IP address will display the content from that certificate when accessed with a secure URL.

    Thank you.
     
  3. maxic9

    maxic9 Registered

    Joined:
    Nov 7, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks, Michael!
    That was my fault - SSL certified web site should have a dedicated IP. Now resolved - changed the IP for "my.new.site"
     
Loading...

Share This Page