The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

www.domain.com/cpanel error

Discussion in 'General Discussion' started by nimahost, Jun 11, 2006.

  1. nimahost

    nimahost Registered

    Joined:
    May 24, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I cant get into /cpanel, /whm, or /webmail..

    here are some errors i found in the logs

    [Sun Jun 11 00:58:02 2006] [error] [client 70.31.76.95] (13)Permission denied: getgrgid: invalid groupid 1007
    [Sun Jun 11 00:58:02 2006] [error] (13)Permission denied: exec of /usr/local/cpanel/cgi-sys/redirect.cgi failed
    [Sun Jun 11 00:58:02 2006] [error] [client 70.31.76.95] Premature end of script headers: /usr/local/cpanel/cgi-sys/redirect.cgi
     
  2. sanjuabrahamk

    sanjuabrahamk Active Member

    Joined:
    Jan 26, 2006
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    Hi,

    Check the permission and ownership of /usr/local/cpanel/cgi-sys/redirect.cgi


    Thanks

    Regards
    Sanju Abraham

    www.mycutelife.net
     
    #2 sanjuabrahamk, Jun 11, 2006
    Last edited: Aug 7, 2007
  3. megabytehosting

    megabytehosting Registered

    Joined:
    May 24, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Please be more specific

    And what would the correct permissions and ownership be?
     
  4. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    # ll -L /usr/local/cpanel/cgi-sys/redirect.cgi
    -rwxr-xr-x 1 root wheel 915 Nov 21 2004 /usr/local/cpanel/cgi-sys/redirect.cgi*
     
  5. mich181189

    mich181189 Member

    Joined:
    Jul 31, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    what is the httpd.conf include line for that file? apache lost it during a config rewrite (as cpanel/whm always messes up in some way...)
     
  6. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Code:
    [B]ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi[/B]
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    
     
  7. mich181189

    mich181189 Member

    Joined:
    Jul 31, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thanks. easyapache always misses this out (well, almost always)
     
  8. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Want a tip?
    Code:
    cp /etc/httpd/conf/httpd.conf /etc/httpd/conf/httpd.conf.ok
    ;)
     
  9. Harilgx

    Harilgx Registered

    Joined:
    May 13, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    )Permission denied: exec of /usr/local/cpanel/cgi-sys/redirect.cgi failed

    make sure that all the files in /usr/local/cpanel/cgi-sys/*.cgi have 755 permission,
    also the files /usr/local/cpanel/base/*.cgi should be under group wheel.

    In /etc/httpd/conf/httpd.conf file check following correctly.
    —————————————————————————————————
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    —————————————————————————————————
    Also try
    /scripts/updatenow
    /scripts/fixeverything
    /scripts/upcp –force

    If that doesn’t even work for you then in httpd.conf change this line
    RLimitMEM 23178922
    and replaced it with
    RLimitMEM 157286400

    Also some times it may happen because of phpsuexec. So you can try turning it off by going to “Enable/Disable SuExec” under “Server Setup” in WHM.

    ========
    Make sure that the permission of /usr/bin/perl is 755 :)
    ========

    Regards,

    Hari
    Logicsupport.com
     
  10. kamihacker

    kamihacker Registered

    Joined:
    Sep 24, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    thanks that fixed my issue after enabling su_exec

    it makes sense :D
     
Loading...

Share This Page