The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

www not working

Discussion in 'General Discussion' started by Ronny, Mar 1, 2004.

  1. Ronny

    Ronny Well-Known Member

    Joined:
    Dec 27, 2002
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    In shell if you do:
    cd /home/username
    ls -l

    do you get a line like:
    lrwxrwxrwx 1 username username 11 Sep 19 14:30 www -> public_html/

    In the VirtualHost entry in your httpd.conf file, do you see a line like:
    ServerAlias www.domain.com domain.com
     
    #2 PWSowner, Mar 1, 2004
    Last edited: Mar 1, 2004
  3. BrightAdmin

    BrightAdmin Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Hi Ronny,

    You should make a CNAME entry for www in your domain's zone file as given:

    www IN CNAME imnewmedia.com


    Regards, :)
     
  4. Ronny

    Ronny Well-Known Member

    Joined:
    Dec 27, 2002
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Yes the Virtual Host is correct, so is the CNAME record.

    I'm able to ping imnewmedia.com but not www.imnewmedia.com so I think it's DNS related, but all DNS settings are correct.
     
  5. Ronny

    Ronny Well-Known Member

    Joined:
    Dec 27, 2002
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
  6. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
  7. Ronny

    Ronny Well-Known Member

    Joined:
    Dec 27, 2002
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Anyone?
     
  8. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    i ended up completely removing the account and recreating it in my case.

    that seemed to fix the issue.
     
  9. myusername

    myusername Well-Known Member
    PartnerNOC

    Joined:
    Mar 6, 2003
    Messages:
    691
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    chown -R us.*yourbase*
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I had the same thing where www worked and without it did not.

    <VirtualHost xxx.xxx.xxx.xxx>
    ServerAlias www.domain.com domain.com

    Add the above line in httpd.con for the domain and it will fix it.

    restart apache when you are done.
     
Loading...

Share This Page