The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

www. won't work with SSL

Discussion in 'General Discussion' started by Drumrocker365, Apr 30, 2014.

  1. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Greetings everyone,

    when ever I try to go to www.mysite.com, it will not load, however, when I go to mysite.com, it will load. Please note that I do force https:// if the visitor is trying to visit with http://. It DID used to work before I added SSL. The certificate is also issued for www.mysite.com so I don't see a reason as to why it will not work.

    Please help!

    Thanks,
    Christian
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you using some sort of CMS for a site, like wordpress? If yes, did you configure the site properly? For example:
    /http://make.wordpress.org/support/user-manual/web-publishing/https-for-wordpress/
     
  3. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hey there,

    No, I did not use a CMS for my site. It's a pure HTML/CSS theme that I customized by hand.
     
  4. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Can you screenshot or copy/paste the exact error you're seeing? Please blur out or omit your domain details though.
     
  5. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    No errors, it just loads forever and ever and says "connecting..." in the bottom left corner (I use Chrome).
     
  6. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Do you have any other sites on this server that use SSL, and if so, do they work? Seems to me that either your server isn't accepting connections on port 443, or your site is redirecting to something it shouldn't be. If you want, PM me your domain and I'll take a look.
     
  7. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    I sent you a PM.
     
  8. Drumrocker365

    Drumrocker365 Well-Known Member

    Joined:
    Apr 15, 2014
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    It was the CloudFlare again, fixed.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page