The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

www.yourdomain.com/~username

Discussion in 'General Discussion' started by paul-ukhost, Oct 9, 2002.

  1. paul-ukhost

    paul-ukhost Well-Known Member

    Joined:
    Sep 2, 2002
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    This feature no longer works since upgrading apache to 1.3.27, is this something that was disabled?

    Just means you cant preview a site before dns updates.
     
  2. Craig

    Craig Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    16
    You don't have mod_bwprotect on do you Paul?

    Any errors?

    Craig.
     
  3. paul-ukhost

    paul-ukhost Well-Known Member

    Joined:
    Sep 2, 2002
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    [quote:067c8f78c8][i:067c8f78c8]Originally posted by Craig[/i:067c8f78c8]

    You don't have mod_bwprotect on do you Paul?

    Any errors?

    Craig. [/quote:067c8f78c8]

    Hi Craig,

    bwprotect was enabled on the previous apache version, the error you get when you try is:

    Access Not Allowed from this Domain
    You are attempting to access a user dir from a domain that is not owned by the user. Please correct the domain that you are attempting to use to access this url.
     
  4. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    It should work with ther accounts IP/~user
     
  5. ukhost

    ukhost Well-Known Member

    Joined:
    Jan 8, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Same thing happens if you try the IP address!! :(

    Kind Regards,

    Neil
     
  6. Craig

    Craig Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    16
    Post what apache mods you are running from the apache status in whm would be ideal.

    Craig.
     
  7. paul-ukhost

    paul-ukhost Well-Known Member

    Joined:
    Sep 2, 2002
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Here you go Craig ~

    Server Version: Apache/1.3.27 (Unix) mod_bwprotect/0.2 mod_log_bytes/0.3 mod_bwlimited/1.0 PHP/4.2.3 FrontPage/5.0.2.2510 mod_ssl/2.8.11 OpenSSL/0.9.6b
     
  8. itf

    itf Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    mod_bwprotect

    [quote:274c013a9a][i:274c013a9a]Originally posted by paul-ukhost[/i:274c013a9a]

    Here you go Craig ~

    Server Version: Apache/1.3.27 (Unix) mod_bwprotect/0.2 mod_log_bytes/0.3 mod_bwlimited/1.0 PHP/4.2.3 FrontPage/5.0.2.2510 mod_ssl/2.8.11 OpenSSL/0.9.6b[/quote:274c013a9a]
    If mod_bwprotect is enabled any user who is not the owner of a domain cannot use user directory this way:
    http://domain.com/~username/
    https://domain.com/~username/

    In this example, username should be the owner of domain.com, if he is not the owner he will get error message “Access Not Allowed from this Domain, You are attempting to access a user dir from a domain that is not owned by the user. Please correct the domain that you are attempting to use to access this url.”

    However, there is an exception to this: host.server-domain.com
    Any user on the system can use user directory from the server FQDN like this:
    http://host.serverdomain.com/~anyuser/
    https://host.serverdomain.com/~anyuser/
     
  9. Craig

    Craig Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    16
    As i suspected..

    You will need to:

    pico /usr/local/apache/conf/httpd.conf

    locate the mod_bwlimited lines and # them out.

    restart httpd

    All sorted :)

    Craig.
     
  10. ozzi4648

    ozzi4648 Guest

    [quote:ec1c890205][i:ec1c890205]Originally posted by paul-ukhost[/i:ec1c890205]

    Hi,

    This feature no longer works since upgrading apache to 1.3.27, is this something that was disabled?

    Just means you cant preview a site before dns updates.[/quote:ec1c890205]

    Hmm, we are still at 1.3.26, how did you update to 1.3.27?
     
  11. mikerayner

    mikerayner Well-Known Member

    Joined:
    Apr 10, 2002
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    [quote:a2caf3d4b1][i:a2caf3d4b1]Originally posted by ozzi4648[/i:a2caf3d4b1]

    Hmm, we are still at 1.3.26, how did you update to 1.3.27?[/quote:a2caf3d4b1]
    use
    /scripts/easyapache
     
  12. paul-ukhost

    paul-ukhost Well-Known Member

    Joined:
    Sep 2, 2002
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    [quote:54eeef1e94][i:54eeef1e94]Originally posted by Craig[/i:54eeef1e94]

    As i suspected..

    You will need to:

    pico /usr/local/apache/conf/httpd.conf

    locate the mod_bwlimited lines and # them out.

    restart httpd

    All sorted :)

    Craig.
    [/quote:54eeef1e94]

    Thanks Craig :)
     
  13. E3000

    E3000 Member

    Joined:
    Feb 2, 2002
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    What is the lines you must comment out?

    thanks
     
  14. YukFoo

    YukFoo Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Try this http://ipnumber/~username/
     
  15. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    comment this lines on your httpd.conf

    # LoadModule bwprotect_module libexec/mod_bwprotect.so
    # AddModule mod_bwprotect.c

    Hope this helps
     
Loading...

Share This Page