The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X-AntiAbuse headers

Discussion in 'E-mail Discussions' started by thobarn, Feb 7, 2010.

  1. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    In the exim configuration file, routers section, X-AntiAbuse headers are added to the outgoing email.
    Code:
    headers_add = "${perl{mailtrapheaders}}"
    Is there an UI option for turning those off? I tried re-writing the routers section in advanced exim configuration but that is not allowed (i.e. duplicate router name error). The only way seems to be manually editing the exim.conf and commenting out the lines from each router description which is over written during update :(
     
  2. acitrano

    acitrano Registered

    Joined:
    Jan 23, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    They claim that if you go into Tweak Settings - Mail and uncheck "Track the origin of messages sent though the mail server by adding the X-Source headers" then they will go away.

    But in my experience, they do not.
     
  3. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    I realized that. The ugly hack I implemented was to re-write the entire ROUTERS section (minus the headers_add lines) in advanced configuration, basically duplication what is in the config but renaming routers. Since the order matters and my routers appear before the default routers, the mail is processed by these rather than default routers. This seems to be the only way to remove the X-Antiabuse headers from the default routers.
     
Loading...

Share This Page