superaca

Registered
Dec 28, 2017
2
0
1
Serbia
cPanel Access Level
Root Administrator
Hello,
I have one one Exchange 2013 (have administartive access) and one cPanel 76.0 (build 9) - I do not have whm access, and administrator of WHM and cPanel is not interested in helping me.

Only, and only when I sent emails from Exchange to that server with cPanel, to any domain that is on that cPanel, "from" address gets rewritten.

I do not have this problem when sending to any other server, even when sending to other servers with cPanel.

I even send one email to two email addresses (destination email addresses are hosted on different cPanel servers, on one "from" gets rewritten on the other one, not !

If you have any idea, where to go from here, please advice.

Thank you.
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,110
660
263
Houston
cPanel Access Level
DataCenter Provider
Hello,
I have one one Exchange 2013 (have administartive access) and one cPanel 76.0 (build 9) - I do not have whm access, and administrator of WHM and cPanel is not interested in helping me.

Only, and only when I sent emails from Exchange to that server with cPanel, to any domain that is on that cPanel, "from" address gets rewritten.

I do not have this problem when sending to any other server, even when sending to other servers with cPanel.

I even send one email to two email addresses (destination email addresses are hosted on different cPanel servers, on one "from" gets rewritten on the other one, not !

If you have any idea, where to go from here, please advice.

Thank you.
Hi @superaca

Can you tell us what you have set for WHM>>Service Configuration>>Exim Configuration Manager ->
EXPERIMENTAL: Rewrite From: header to match actual sender

On both servers? Is it the same?


Thanks!
 

superaca

Registered
Dec 28, 2017
2
0
1
Serbia
cPanel Access Level
Root Administrator
Hi,
I have asked WHM administrator is this turned on. It is turned on and set to "ALL".
This is on WHM (recipient email server), and on Exchange side (sender email server) this option is of course not present.
Any idea ?