Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

X-Source Headers Problem

Discussion in 'General Discussion' started by derekivey, Aug 23, 2006.

  1. derekivey

    derekivey Well-Known Member

    Joined:
    Nov 30, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    156
    Hi,

    Today our server received an abuse report for spam coming from it. Our host advised us to enable X-Source headers in WHM. I did that today, and sent myself an email using PHP, and noticed that they weren't being added. I tried the same on my friend's server and they were there on his. Does anyone know why it's not working on my server?

    Thanks,
    Derek
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    It depends on how you configured your Php scripts. But did you try sending a message using Web Mail, or an email client like MS Outlook/Outlook Express?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. derekivey

    derekivey Well-Known Member

    Joined:
    Nov 30, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    156
    I ended up disabling that setting because it was preventing anyone from sending out any mail to outside servers. I was only able to email people on the same server, the others were just giving me an unroutable domain error in the exim_mainlog. Any ideas why that us happening?

    Thanks,
    Derek
     
  4. Voltio

    Voltio Active Member

    Joined:
    Oct 17, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    156
    I have the same problem, I remember I had X-Source Headers enabled in an old server and it used to work with the script im using to test X-Source, but this time its not working...
     
  5. derekivey

    derekivey Well-Known Member

    Joined:
    Nov 30, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    156
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice