The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X-Spam-Score Headers Missing Entirely

Discussion in 'E-mail Discussions' started by DavidR, Apr 23, 2013.

  1. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    I'm not sure what happened, but apparently there was a major update to how SpamAssassin works and I didn't notice. Things were working nicely at one time, but now I don't seem to be able to make the x-spam headers work -- there are none in any of the emails, ham or spam. I've been reading over explanations and fixes for a couple of hours and it's not sinking in. Does someone have a starting place for me to check this? Before, it would show the scores for all email in the header. This is preferable for us to the ***SPAM*** subject rewrite.

    I'm running WHM 11.36.1 (build 5) on a Centos 5.9 VPS

    Thanks for any help.
     
  2. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    I'm getting nowhere with this. I'm not even entirely sure spamassassin is running, except for one "spamd child" process that is using a tiny bit of memory (as I remember, this should be very active). I'm trying to go by the cPanel guide which matches my version, but things aren't matching up. There is no Enable Spamassassin or Auto Delete Spam button that I can find in the Exim configuration. This used to be pretty easy, but I'm stumbling here. Is there a more up-to-date guide?
     
  3. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    SpamAssassin, and automatic deletion of spam, are enabled and disabled in cPanel. That is why you do not see options for them in the Exim configuration editor.

    In Home » Server Configuration » Tweak Settings and Home » Service Configuration » Service Manager, make sure that SpamAssassin is enabled, then log into cPanel for the account and click the SpamAssassin icon. That is where you will find the options to enable and disable it for the account, set the threshold desired, and enable or disable automatic deletion of spam.
     
  4. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for your response Jared. I had just found the settings in cPanel -- felt a bit silly for missing that but they were set correctly, as were the two you mentioned. One interesting thing, I enabled "Old Style Spam System" and it started working, spam headers and all. Of course, now spamd is using gobs of CPU. Does the fact that it works with the old system mean anything to you concerning my problem?
     
  5. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    It's definitely working with the "Old Style Spam System" set, but using way too many resources. I can't keep it in this mode. I've yet to figure out why it works and the normal way doesn't. Any ideas?
     
Loading...

Share This Page