The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X11BASE error in freebsd ??

Discussion in 'General Discussion' started by nyjimbo, Jul 1, 2007.

  1. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    I just noticed that on our older freebsd servers (pre-6.2) when something is trying to "make" we get the following error:

    'On FreeBSD before 6.2 ports system unfortunately can not set default X11BASE by itself so please help it a bit by setting X11BASE=${LOCALBASE} in make.conf.
    On the other hand, if you do wish to use non-default X11BASE, please set variable USE_NONDEFAULT_X11BASE.
    *** Error code 1

    Stop.'

    This only seems to be happening now on our cpanel servers, as if something was updated on them but either its broken now or not fully updated. If I run makes on our non-cpanel boxes this error does not occur.

    Does anyone know what this is about?. Why is it happening now, we didnt see it a few months ago and it seems to be only when "make" runs, especially during upcp when it
    tries to do its updates of things like exim, mysql, etc...


    :confused:
     
  2. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Yep...started about a month ago. Has to do with the way ports are called from cpanel by the looks of it.

    Add the following line to

    /etc/make.conf

    X11BASE=${LOCALBASE}

    Then your files will update.
     
Loading...

Share This Page