The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X3 Branding Error - missing-bid: logo-top-logo

Discussion in 'User Experience' started by chriscory, Oct 3, 2010.

  1. chriscory

    chriscory Member

    Joined:
    Oct 3, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone, well I cannot find what may cause this issue:

    When I want to customize X3 themes logos, a banner appears saying: missing-bid: logo-top-logo

    I'm stuck at this point, the top billboard banner doesn't appear, when i try to change the logos, they don't change.

    Please I will appreciate your help.
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please check the cPanel error_log for more information

    Please check the cPanel error_log to look for more verbose details; any additional information may help diagnose why the issue is occurring.

    The cPanel error_log can be found at the following path:
    Code:
    /usr/local/cpanel/logs/error_log
    To monitor the error_log for new messages (while testing via cPanel/WHM), consider using "tail" as seen below:
    Code:
    # tail -fvn0 /usr/local/cpanel/logs/error_log
     
  3. nbd9gn1

    nbd9gn1 Member

    Joined:
    Jan 20, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Was their a resolution to this? I am having the same problem, but do not have root access!
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I'm not aware of any other news from the original poster.

    Do you have reseller access to WHM? Have you contacted your upstream hosting provider to report the issue? If needed, the upstream host, with "root" (Administrator) access, can submit a support request on your behalf.

    Which X3 style, also known as a branding package, is being used when the error occurs?
     
  5. nbd9gn1

    nbd9gn1 Member

    Joined:
    Jan 20, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you Don for your reply. Yes I do have a reseller account with Hostgator. I have not contacted them as of yet. Was just curious if there might be an easy fix to this issue. I was rebranding a custom style under X3 theme. I will let you know of any resolution.
    Kathy
     
  6. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Is the custom style based off of one of the stock-default X3 styles or, perhaps, Blueroy? I'm curious if the same issue occurs with the original (stock-default) style that was used for further customization. To note, cPanel Blueroy was not designed for use in the X3 Live Branding Editor.

    When contacting your upstream host, I recommend asking them to monitor the cPanel error_log when triggering the "missing-bid: logo-top-logo" message in the X3 Live Branding Editor; the cPanel error_log may have clues pointing to a potential cause or provide other information to help narrow the scope of investigation.

    Do you have SSH access? If yes, I would also search your home directory for files not owned by your username, perhaps in the "~/.cpanel/" sub-directory. The following command, entered via SSH access, should help with this task:
    Code:
    # find ~/.cpanel ! -user ${whoami} -exec stat '{}' \;
     
  7. nbd9gn1

    nbd9gn1 Member

    Joined:
    Jan 20, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Don, thanks again for your response.
    I was working off of a copy of the 'sundaymorning' as well as the 'default' styles. I received the error from both. I did put in a trouble ticket with Hostgator, but have not heard back. I will pass along your suggestion for monitoring the cPanel error_log. I don't have SSH access right now, but I was planning on requesting it from HG. I'll let you know what they fine. Thank you. Kathy
     
  8. nbd9gn1

    nbd9gn1 Member

    Joined:
    Jan 20, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello Don,

    I just wanted to let you know that my issue is resolved. HG did not get back to me so I decided to look into the .cpanel directory some more. I ended up deleting some of the files: .cpanel/nvdata.cache ; .cpanel/caches/statcache_persistant; and .cpanel/nvdata/x3_litegraphics

    I know I should have deleted them one at a time to see which one was the problem, but I kind of did it on a whim. At any rate, it resolved my error.

    Thank you for taking the time to look into this for me.
    I'm sure I'll be back to this forum again. :)

    Kathy
     
  9. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    You're welcome. :)

    Of the files listed, I believe the most plausible cause may related to the "~/.cpanel/nvdata.cache" file. The following may or may not have been the specific problem, but during my research I found one instance where the "missing-bid: logo-top-logo" message was triggered when incorrect ownership or access permissions prevented the "nvdata.cache" file from being updated or written to, which would interfere with use of the X3 Branding Live Editor.

    Notes for locating the appropriate "nvdata.cache" file:
    • For Administrators using the X3 Branding Live Editor via "root" access to WHM, the "nvdata.cache" file is located at the following file system path:
      Code:
      /var/cpanel/userhomes/cpanel/.cpanel/nvdata.cache
    • For cPanel users and resellers with WHM access, the applicable "nvdata.cache" file is located in the user's home directory, as seen below; in these examples, "~/" refers to the home directory of the user currently logged-in, via SSH for example, and "~username/" refers to the home directory of a specific username, which may help Administrators save time (on the command-line in SSH) from not having to type the "/home/" part of the directory path:
      Code:
      /home/username/.cpanel/nvdata.cache
      ~username/.cpanel/nvdata.cache
      ~/.cpanel/nvdata.cache
     
Loading...

Share This Page