The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

x86_64 Apache Build Problem

Discussion in 'EasyApache' started by kofi, Aug 20, 2005.

  1. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    I'm getting the following error when trying to compile apache in x86_64, anybody have any ideas how to fix?

    make -j 1 apache_1.3.33..................Done
    make[4]: *** [ssl_expr_scan.c] Error 127
    make[3]: *** [all] Error 1
    make[2]: *** [subdirs] Error 1
    make[1]: *** [build-std] Error 2
    make: *** [build] Error 2
    make apache_1.3.33...(install)....Done
    make[5]: *** [ssl_expr_scan.c] Error 127
    make[4]: *** [all] Error 1
    make[3]: *** [subdirs] Error 1
    make[2]: *** [build-std] Error 2
    make[1]: *** [build] Error 2
    make: *** [install-all] Error 2
    /etc/rc.d/init.d/httpd: line 89: /usr/local/apache/bin/httpd: No such file or directory
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Setting /home permissions to 0711......Done

    ....


    configure curl-7.12.0...(--libdir=/usr/lib64 --prefix=/usr)........Done
    configure: error: C++ preprocessor "/lib/cpp" fails sanity check
    See `config.log' for more details.
    make -j 1 curl-7.12.0..........Done
    configure: error: C++ preprocessor "/lib/cpp" fails sanity check
    See `config.log' for more details.
    make: *** [all] Error 1

    ...


    make -j 1 ming-0.3beta1...........Done
    gifdbl.c:31: error: syntax error before '*' token
    gifdbl.c: In function `getTransparentColor':
    gifdbl.c:34: error: `ExtensionBlock' undeclared (first use in this function)
    gifdbl.c:34: error: (Each undeclared identifier is reported only once
    gifdbl.c:34: error: for each function it appears in.)
    gifdbl.c:34: error: `ext' undeclared (first use in this function)
    gifdbl.c:34: error: `file' undeclared (first use in this function)
    gifdbl.c:38: error: `GRAPHICS_EXT_FUNC_CODE' undeclared (first use in this function)

    (these errors go on for a while)

    ...

    12:01:31 URL:http://layer1.cpanel.net/buildapache/1/php-4.3.11.tar.gz [4,875,262/4,875,262] -> "php-4.3.11.tar.gz" [1]
    Untarring php....Done
    x86_64 detected.. patching/rebuilding php configure.....sh: libtoolize: command not found
    sh: line 1: aclocal: command not found
    cat: /libtool.m4: No such file or directory
    Forcing buildconf
    using default Zend directory
    buildconf: checking installation...
    buildconf: autoconf not found.
    You need autoconf version 2.13 or newer installed
    to build PHP from CVS.
    make: *** [buildmk.stamp] Error 1

    ....

    make php-4.3.11...(install)...Done
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd: line 89: /usr/local/apache/bin/httpd: No such file or directory
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Waiting for httpd to restart..............finished.


    httpd has failed, please contact the sysadmin.



    -----


    I have heard some people mention linking the /lib to /lib64, would this help?
     
    #1 kofi, Aug 20, 2005
    Last edited: Aug 20, 2005
  2. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Anybody had success with x86_64 (CentOS 4.1)?
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    try

    yum install cpp
     
  4. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Nick, thanks for the reply. It seems that cpp is already installed:

    rpm -qa | grep cpp
    cpp-3.4.3-22.1

    Any other missing package which might be causing the issue?
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    try

    gcc-c++
     
  6. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Seems that the problem has already been fixed by cPanel support (just a few minutes ago):

    "The fontconfig-2.2.3-7 RPM that was installed on the server was causing other system RPMs not to update. I went ahead and uninstalled that RPM and ran easyapache and it appears to be working OK now."

    I'll update this thread if I still have problems. (btw, gcc-c++ package was not installed, and I just installed this).
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Thats a known problem with RHE 4 and Centos 4.

    fontconfig has a dependency that can never be resolved on x86_64


    You may have to do

    rpm -e fontconfig

    if you have other problems installing rpms.
     
  8. kofi

    kofi Well-Known Member
    PartnerNOC

    Joined:
    Feb 3, 2004
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Nick for the update, this is my first time installed CentOS in x86_64 and thats some useful info :) I have noted it for all further installs.
     
  9. promak

    promak Well-Known Member

    Joined:
    Oct 6, 2001
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    x86_64 easyapache issue

    Hi ,

    Just Install Centos in My New Intel x86 system with SATA HD.

    after install cPanel , and need reinstall the apache for get some module.

    but find same error with this post , i do a search in cpanel forum , fix some issue and can get php online again.

    I have try....
    yum install cpp
    yum install gcc-c++
    rpm -e --justdb --nodeps fontconfig fontconfig-devel

    before show error is
    configure: error: cannot find output from lex; giving up
    configure: error: cannot find output from lex; giving up

    Now the apache is up and php is up , but there have some error in whm easyapache when i use to build the apache.

    Nick , any advice for this ?

    libtiff-devel /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /usr/lib have same soname but different type.

    and

    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home permissions to 0711......Done
    Setting permissions for........Done
    Untarring php....Done
    x86_64 detected.. patching/rebuilding php configure.....New Libtool detected.. applying patch!
    patching file acinclude.m4
    Hunk #1 succeeded at 783 with fuzz 2 (offset -38 lines).
    You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
    Forcing buildconf
    using default Zend directory
    buildconf: checking installation...
    buildconf: autoconf version 2.59 (ok)
    buildconf: Your version of autoconf likely contains buggy cache code.
    Running cvsclean for you.
    To avoid this, install autoconf-2.13 and automake-1.5.
    rebuilding aclocal.m4
    rebuilding configure
    rebuilding main/php_config.h.in
    autoheader: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
    autoheader: WARNING: and `config.h.top', to define templates for `config.h.in'
    autoheader: WARNING: is deprecated and discouraged.
    autoheader:
    autoheader: WARNING: Using the third argument of `AC_DEFINE' and
    autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
    autoheader: WARNING: `acconfig.h':
    autoheader:
    autoheader: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1,
    autoheader: [Define if a function `main' is needed.])
    autoheader:
    autoheader: WARNING: More sophisticated templates can also be produced, see the
    autoheader: WARNING: documentation.
    Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).

    configure php-4.4.1...(--enable-pic --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --enable-ftp --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    Thanks.

    Hope this can fix and so the X86_64 in Centos or REdhat Enterprise more and more people to use.
     
  10. ukhost4u

    ukhost4u Active Member
    PartnerNOC

    Joined:
    Apr 24, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    To clear the lex error run:

    yum install flex
     
  11. laborspy

    laborspy Well-Known Member

    Joined:
    Feb 7, 2004
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    I had the same problem, it seems some items in the Update Apache screen are not 100% compatible with x86_64. I unchecked the IMAP support and it worked fine afterwords.
     
  12. ukhost4u

    ukhost4u Active Member
    PartnerNOC

    Joined:
    Apr 24, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Yes IMAP won't work and never will GD. I sent a ticket to cPanel and they fixed GD though as there was missing lib's.
     
  13. laborspy

    laborspy Well-Known Member

    Joined:
    Feb 7, 2004
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    No I have GD working fine. I gave cPanel access and they ended up telling me that it was the calendar support messing it up and left it at that. One thing I wish cPanel would do is if there is problems with something then don't allow me to select it until it is fixed.


     
    #13 laborspy, Mar 17, 2006
    Last edited: Mar 17, 2006
  14. faqall

    faqall Active Member

    Joined:
    Jul 17, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Is there any fix for this out there. Just today i had to run easyapache and now i cannot get it running again. Even configuring it in fail safe mode.

    WHM 10.8.0 cPanel 10.8.1-S114
    CentOS 4.2 i686 - WHM X v3.1.0

    EDIT:
    This is only when upgrading php to 4.4.1 or 4.4.2

    4.3.11 works just fine.

    Any comments or suggestions. Any more information needed?
     
    #14 faqall, Mar 20, 2006
    Last edited: Mar 20, 2006
  15. ukhost4u

    ukhost4u Active Member
    PartnerNOC

    Joined:
    Apr 24, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Do you have the error message you are getting? Also what version of cPanel are you running.

    I found 2 things that might help:

    1) Use the EDGE build as it has a lot of X64 fixes
    2) You might need to manually install some programs with YUM and dep on your O/S remove some as well.

    Get me the error anyway and I might be able to help.
     
  16. faqall

    faqall Active Member

    Joined:
    Jul 17, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Well thats just it. I get no errors. It builds apache just fine. However at the end it simply says apache build failed. Then when I go to restart the service (service httpd restart) it will tell me that apache is not running, restarting apache, apache started... when in fact it never really was started (even after restarting it several times + doing stop/start). It will do this with any build regardless of what i have applied. I can do the most basic configuration and it will still fail. Even when I do a fail safe compile... it still goes bad. My only solution was to revert back to php 4.3.11 which works 100% fine regardless of what I compile it with.
     
  17. promak

    promak Well-Known Member

    Joined:
    Oct 6, 2001
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    i just enable the following in easyapache. hope if someone still can't get apache up , can check this.

    './configure' '--enable-pic' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-iconv' '--enable-memory-limit' '--enable-magic-quotes' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'

    and i hope nick can mark down which one is not support under x86_64 as said before , ming not support 64 bit yet.

    also , any one using FreeBSD 5.x and 6.x work normal with easyapache?

    Thanks & Regards.
     
  18. faqall

    faqall Active Member

    Joined:
    Jul 17, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    So you want me to try them settings via easyapache...? is there anyway for me to simply copy and paste them after the ./easyapache ... or am i wishing for too much simplicity?


    thanks in advanced!
     
  19. bjarne

    bjarne Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    IMAP module don't work all else seems good

    Hi!

    I have a few boxes running Centos 4 64bit with WHM, regardning apache there are some problem with libs relatet to IMAP - besides that we have not yet had any problems - we actualy run a few bigger sites (in our standard) and there have been zero problems so far - I think it is safe to say Centos 4-2 64 is a good thing.
     
  20. ukhost4u

    ukhost4u Active Member
    PartnerNOC

    Joined:
    Apr 24, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Yea, I have to agree that expect from a couple of install bugs I am very happy with the AMD 64 system with cPanel and centos.

    I have to also say cPanel are much happer to help with 64 version of cPanel now more than they ever were before.

    I have also noticed that with my systems, AMD 64 X2 is so much faster than I ever expected.
     
Loading...

Share This Page