The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

xfer streaming support not supported !

Discussion in 'General Discussion' started by Metro2, Apr 25, 2010.

  1. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    When I use the "WHM > Transfers > Copy an account from another server" feature to copy individual accounts from one server to another, it usually works great.

    But recently I'm having trouble copying accounts this way from just one server in particular in my cluster.

    What happens:

    There is an EXTREMELY long wait and then I get the following message:

    "Testing xxx.xxx.xxx.xxx for xfer streaming support....Not Supported!"

    And then the transfer will eventually work, but it appears to be using a very slow / outdated method.

    I've done a lot of Copying accounts from server to server via the "WHM > Transfers > Copy an account from another server" in recent years on my servers, but have never run into this problem before. If I have to keep going like this it will take me a week to transfer the accounts from one of my old servers to my new one :(

    Does anyone know how can I enable xfer streaming support on a given server?

    I cannot find anything in the forums, google, or cpanel/whm documentation.

    I'm running RHEL 4, cPanel 11.25, apache 2.2.x, php 5.2.13

    Thanks for any suggestions!
     
  2. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    The solution (in my case) was really a stupid simple oversight on my part due to lack of sleep / not thinking straight. With the help of cPanel support I was reminded that since I use CSF/LFD, I needed to make an entry in "csf.allow" for a new server added to my dns cluster in order for xfer to be able to connect properly (since CSF will block unknown servers on certain ports for this function). Hope that answer helps someone else who might run into this problem too. Many thanks to cPanel support for ultimately spotting this omission on my part!
     
  3. wizzy420

    wizzy420 Well-Known Member

    Joined:
    Nov 13, 2007
    Messages:
    125
    Likes Received:
    2
    Trophy Points:
    18
    For those looking for details

    It seems to be specifically port 2086, outbound.

    So in CSF config add 2086 to the "TCP_OUT" line

    Restart CSF, xfer streaming works.
     
  4. EdwardMillen

    EdwardMillen Registered

    Joined:
    May 25, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    For anyone else experiencing this issue, here's what was causing it for me. I had managed to transfer a couple of accounts with xfer streaming turned on, but it stopped working after I changed a completely unrelated setting in WHM to try to fix a problem with one of the account transfers.

    The problem turned out to be caused by the "Require SSL" setting being turned on when I saved the other setting (as that setting didn't exist last time I changed any settings, so WHM set it to the default, which is On).

    Turning that back off made it work again, but then I also discovered that the "Use SSL" checkbox on the single account copy page basically seems to be the wrong way round. With it ticked, the xfer streaming tries to connect over HTTP, which it couldn't do when Require SSL was enabled on the remote server so it decided xfer streaming wasn't supported. With "Use SSL" unticked though, it actually streams the homedir over HTTPS and therefore also works with Require SSL enabled.

    The copy multiple accounts page seems to work correctly with Use SSL ticked though, so either it works the right way round on that page or it just ignores the setting and always uses HTTPS.
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    As an FYI, this problem is still not resolved. If you have the box checked "Use SSL" it still streams over the non-SSL WHM port of 2086.

    For me, this caused streaming to fail due to the donor server not having that port opened. To fix, the donor server was changed to have TCP port 2086 Outbound allowed -- which solved my problem with streaming for now.

    - Scott
     
  6. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    For the "Copy multiple accounts/packages from another server", where you can move more than one account at a time, Streaming will NOT work if the server you are moving the accounts from is Forcing SSL in Tweak Settings.

    There are two settings you must change:

    WHM >> Server Configuration >> Tweak Settings > Redirection > Always Redirect to SSL [OFF]
    WHM >> Server Configuration >> Tweak Settings > Security > Require SSL [OFF]

    Of course, it's recommended to return these settings to [ON] once the transfer has completed for security reasons.

    This information is per cPanel Ticket 2047386.

    - Scott
     
  7. davetanguay

    davetanguay Active Member

    Joined:
    Mar 30, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I notice streaming support is not working when I copy multiple accounts on cpanel11.primary001.net > WHM > Copy multiple accounts/packages from another server

    I am using the following settings:

    =========================
    Remote Server Address: x.x.x.x
    Remote SSH port: 22
    Don't Compress Transfer: not checked
    Use SSL: checked
    Use Incremental Backups speed-up: not checked
    Allow Override: not checked
    Login: Root
    Authentication Method: Public Key
    Use FTP to Transfer: not checked
    =========================

    No matter what settings I try, it never streams the /home directory for the user. It always packages the /home folder for the user. I've tried using both the server IP and the Hostname to connect. I tried disabling CSF, but still no luck.

    I have set the following correctly on the server on both servers

    WHM >> Server Configuration >> Tweak Settings > Redirection > Always Redirect to SSL [OFF]
    WHM >> Server Configuration >> Tweak Settings > Security > Require SSL [OFF]

    Within the CSF config, I add 2086 to the "TCP_OUT" line. I also added each server's IP to /etc/csf/csf.allow on both servers and restarted CSF.

    I have some very large sites that need to be moved in the coming days and need it to stream instead of packaging the entire home folder of the user. I see a lot of problems with this on the cPanel forums.

    Any further ideas?
     
  8. davetanguay

    davetanguay Active Member

    Joined:
    Mar 30, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I got it working. The problem for me was it will not work if I use:

    Authentication Method: Public Key

    I tried using Password instead and it works just fine!
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you submit a ticket for us to investigate this further? You can submit one using WHM > Support Center > Contact cPanel or using the link in my signature. Please post that ticket number after submitting one so we can track the resolution for future reference. Thanks!
     

Share This Page