xfercpanel not working and reports "You must specify a username to log in."

BrianLayman

Member
Aug 3, 2009
12
1
53
From List Accounts the cPanel button is not working.
I've had this issue before around a time when there was a cPanel update and a reboot fixed it. It's not fixing it this time.
I've gone into Tweak Settings and confirmed that " System>Accounts that can access a cPanel user account:" is set to: "Root, Account-Owner, and cPanel User" (I also changed it to something else and changed it back.)
I've confirmed that root is the owner of all the accounts.
I've modified my pro package and confirmed it is set to have root as the owner and tried to access from a pro account.
I've re-assigned my root password.
Still, after clicking that cpanel button on list accounts, I just get an error message.

What else can I look at?

1658520475336.png
 

andrew.n

Well-Known Member
Jun 9, 2020
915
342
63
EU
cPanel Access Level
Root Administrator
hm interesting. Can you try to suspend the account then unsuspend it and try? cookies are enabled in your browser? Can you try this from a different browser as well?
 

BrianLayman

Member
Aug 3, 2009
12
1
53
Thanks Andrew and CPRex, this has been going on for months now and it was for EVERY account, even my own accounts, not just one in particular. Every time I had to go into someone's cpanel, I had to reset their password. Fortunately it wasn't all that often. So I could ignore it for the most part. When I decided on Saturday to post to the forum finally, I re-confirmed I had done all of those steps I listed in the OP. And the behavior continued. So I posted.

But now.. I had to add a subdomain for someone and I realized that I had just successfully gone into their cpanel. I'm able to do that with accounts I had trouble in and other accounts I hadn't.

So, ummm, thank you for scaring the problem away. I've learned that if asking (or being asked) for support solves the problem, you should just accept the win. So, I'm not going to dig into it further at this time and will assume one of the actions I did above eventually fixed the issue. So thank you! I'll see you if it comes back.
 
  • Like
Reactions: andrew.n