Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Xferlog of Proftpd is not output.

Discussion in 'General Discussion' started by toyama, Apr 10, 2012.

  1. toyama

    toyama Member

    Joined:
    Jun 17, 2011
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    53
    The following log is printed to /var/log/messeges and ftp access, will not be written to xferlog.
    -------------------------------------------------- ----------------------
    Apr 10 18:04:58 host proftpd [8111]: xxx.xxx.xxx.xxx :): ffff: xxx.xxx.xxx.xxx [:: ffff: xxx.xxx.xxx.xxx]) - unable to open TransferLog '/ var / log / xferlog': Too many levels of symbolic links
    Apr 10 18:23:54 host proftpd [9738]: xxx.xxx.xxx.xxx :): ffff: xxx.xxx.xxx.xxx [:: ffff: xxx.xxx.xxx.xxx]) - unable to open TransferLog '/ var / log / xferlog': Too many levels of symbolic links
    -------------------------------------------------- ----------------------

    I created a ftp account one by one to 35 domains.

    cPanel environment is as follows.
    --------------------------------------------------
    root@host[/var/log]# proftpd -v
    ProFTPD Version 1.3.3g
    root@host [/var/log]# uname -r
    2.6.32-220.4.1.el6.x86_64
    root@host [/var/log]# cat /etc/redhat-release
    CentOS release 6.2 (Final)
    root@host [/var/log]# /usr/local/cpanel/cpa
    cpaddons/ cpanel cpanel-email cpanellogd
    root@host [/var/log]# /usr/local/cpanel/cpanel -V
    11.30.6 (build 6)
    --------------------------------------------------

    Do you want to solve I do?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Do you have the following set to On or Off in WHM > Tweak Settings area?

    If it is set to Off, then that log won't be kept and does wipe after logs process.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. toyama

    toyama Member

    Joined:
    Jun 17, 2011
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    53
    Thank you for the answer.

    "Keep master FTP log file" has set to "Off".

    Explanation was not enough.

    Is "Keep master FTP log file" If Off, is /usr/local/apache/domlogs/ftpxferlog empty (0 byte),
    Is a lotus which the logs are separated into "ftp.DOMAINNAME-ftp_log".
    However, "ftp.DOMAINNAME-ftp_log" is not written.
    The problem is that it is not separated into "ftp.DOMAINNAME-ftp_log".

    We guess there is a problem with the process of separation, and if they are really of being a log of the following output.
    -------------------------------------------------- ----------------------
    Apr 10 18:04:58 host proftpd [8111]: xxx.xxx.xxx.xxx :): ffff: xxx.xxx.xxx.xxx [:: ffff: xxx.xxx.xxx.xxx]) - unable to open TransferLog '/ var / log / xferlog': Too many levels of symbolic links
    Apr 10 18:23:54 host proftpd [9738]: xxx.xxx.xxx.xxx :): ffff: xxx.xxx.xxx.xxx [:: ffff: xxx.xxx.xxx.xxx]) - unable to open TransferLog '/ var / log / xferlog': Too many levels of symbolic links
    -------------------------------------------------- ----------------------

    Then I fix this problem? Set to "On" the "Keep master FTP log file"?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I don't even have any symlink or anything at /var/log/xferlog on my system. Did you create a symlink there or did something else? If you do fix that issue, you could certainly then change that value to On and keep all the FTP logs in /usr/local/apache/domlogs/ftpxferlog without wiping that log file.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. toyama

    toyama Member

    Joined:
    Jun 17, 2011
    Messages:
    21
    Likes Received:
    1
    Trophy Points:
    53
    Thank you, been resolved.

    "/var/log/xferlog", the symbolic link has been created to "../../usr/local/apache/domlogs/ftpxferlog".
    Was resolved to delete the symbolic link, After restarting the Proftpd.

    This symbolic link is not to your own specifications.
    What had been so I do not know why. :confused:
     
Loading...
Similar Threads - Xferlog Proftpd output
  1. stefanbc
    Replies:
    5
    Views:
    386

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice