The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XINETD and IMAP have Failed

Discussion in 'General Discussion' started by HD-Sam, Apr 8, 2004.

  1. HD-Sam

    HD-Sam Active Member
    PartnerNOC

    Joined:
    Sep 23, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iowa City, Iowa
    My XINETD and IMAP have failed.

    If you try to restart xinetd it doesn't do anything.
    For Example. If you type "service xinetd restart" It goes straight back to the command prompt, it doesn't say OK or do anything.

    If you do "/scripts/restartsrv imap" It says imap restart failed, contact sysadmin.

    I have tried doing
    /scripts/fixcommonproblems
    /scripts/upcp

    and have also rebuilt apache (/scripts/easyapache).

    None of them did anything to correct the issue.

    I also removed the rpms for imap and xinetd and reinstalled them. That did not work either.

    Any ideas anyone?

    I'm Running RHEL 3.0 w/ cpanel 9.10-s93
     
  2. HD-Sam

    HD-Sam Active Member
    PartnerNOC

    Joined:
    Sep 23, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iowa City, Iowa
    All thanks goes to Daniel Muey,

    What a Tech I tell you.

    Many EV1 Techs looked at the problem and the EV1 Trouble ticket was open for 2 days without resolution. No one could figure it out.


    I opened my ticket with cPanel, a few hours later Daniel logged in and wow everything works :)

    I'm not sure how, but my /etc/sysconfig/network file was empty.

    He just re-edited the file with the proper info and now both XINETD and IMAP are functioning properly.

    Thanks Daniel :)
     
  3. Brando

    Brando Member

    Joined:
    Nov 6, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I was having the same problems as sweet9 as well. xinetd wudn't start properly, and imap keeps failing as well. based on what sweet9 wrote here, i checked the /etc/sysconfig/network file on another server and found the necessary things to insert /etc/sysconfig/network on the problematic server.

    just edit /etc/sysconfig/network with the following, inserting your own values where necessary:

    NETWORKING=yes
    HOSTNAME="your.domain.com"
    GATEWAY="203.106.52.1"
    GATEWAYDEV="eth0"
    FORWARD_IPV4="yes"

    replace your.domain.com with your own server hostname and gateway with your gateway IP. hope this helps anyone who might come across the same problem as me :)
     
Loading...
Similar Threads - XINETD IMAP Failed
  1. Chris-777
    Replies:
    3
    Views:
    420

Share This Page