The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XXX is currently not permitted to relay through this server

Discussion in 'E-mail Discussions' started by KrystalS, Jun 25, 2008.

  1. KrystalS

    KrystalS Active Member

    Joined:
    Mar 15, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    UK
    Hi guys.

    We are having a problem with Exim :

    One user of one domain is getting the following errors :

    Their Mail client gives them a 530 Error - Couldn't send.

    The authentication is 100% correct, as sometimes mails Do send!

    I've also checked /etc/localdomains for their domain - and it's there!

    What could be causing this ?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    If you look in /var/log/exim_main and you do not see a fixed_login entry for that individual, then they do not have SMTP Auth enabled. If they do and are using the wrong credentials, you'll see that in the fixed_login line.

    An invalid authentication
    2008-06-22 11:03:08 fixed_login authenticator failed for (localhost.localdomain) [xx.xx.xx.xx]: 501 Authentication cancelled

    An invalid authentication
    2008-06-25 13:25:51 fixed_login authenticator failed for (yourkybtg65gxe) [xx.xx.xx.xx]: 535 Incorrect authentication data (set_id=someotherperson@someotherdomain.com)

    A valid authentication
    2008-06-22 11:29:18 1KARVF-0007TJ-Sx <= someone@somedomain.com H=c-xx-xx-xx-xx.hsd1.or.comcast.net (BILLY) [xx.xx.xx.xx] P=esmtpa A=fixed_login:someone@somedomain.com S=4068 T=""

    Notice all of those lines have 'fixed_login' in them - indicating that some sort of authentication was attempted and either passed or failed for some reason. If you don't see a similar entry during the time that particular email of your client's was sent, then they weren't using SMTP Auth. If you do see a line with 'fixed_login' in it, it should indicate why the authentication failed.

    Also, not only make sure that your client's domain does exist in /etc/localdomains but also that it does not exist in /etc/remotedomains.

    Mike
     
  3. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    I have the same problem, but... how can we override this comprobation of the IP address??... I don't want to pass though this comprobation....

    Thanks...
     
  4. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    No one knows how to solve this issue?

    I have this problem when I updated exim, mailscanner and clamv.
    (all this day I have this problem).

    1) autentication is fine, the domains CAN receive email.
    2) When a domain send email, appears the error:

    [xxx] F=<xxx@xxx.dot.tld> rejected RCPT <xxx@xxx.dot.tld>: (XXX) [xxx] is currently not permitted to relay through this server. Perhaps you have not logged into the pop/imap server in the last 30 minutes or do not have SMTP Authentication turned on in your email client.

    3) When I add the IP in Main >> Service Configuration >> Exim Configuration Editor... in the ACCESS LISTS >> Whitelist, I CAN SEND EMAIL, but... I don't want this, I will write all the domains-client-email IPs??, impossible, And the ADSLs have dynamic IP address... I disable this options (blacklist and whitelist)... but the problem persists...

    HOW TO FIX THIS???
     
  5. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    I find a temp solution but... is not the idea... this happen when I updated all.... (always is the same...)

    put a block of your common Ips in the Whitelist:

    Example:

    200.0.0.0/18
    199.0.0.0/18

    Obviously, put only the trusted and acord to your customer's country. (or where they will use email clients...)

    Any one have other and better fix?
     
Loading...

Share This Page