The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

YAML Erorr + Ptys Error

Discussion in 'General Discussion' started by Starcraftmazter, May 20, 2007.

  1. Starcraftmazter

    Starcraftmazter Well-Known Member

    Joined:
    May 5, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Hello.
    2 problems...or so.

    I just updated to the latest cpanel/whm (I was on the edge tree.....still ><), because of a file manager problem, and now I get this error in many places:

    Can't locate YAML/Syck.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /scripts/cPScript/DataStore.pm line 11.

    Thats for a cPanel update, but I get one with tiny.pm as well.
    I've looked all over the forums, and I really am not sure how to fix it, though I've looked at some cpaddons solutions, I don't see how that can apply here, plus there are about 100 accounts on the server.


    Now the second problem which sometimes occurs - for example when I try to install perl modules in whm - is, "the system has run out of ptys".

    Now I've searched solutions for that, and I've done everything, including running many whm scripts, making sure those dev folders are there with the right permissions, restarted a million times - and the error persists.


    Oh and another problem....cPanel loads blank (whm works thankfully though).

    My plan is not upgrade to the latest current version which seems to be newer than the one I'm running? I'm running:
    WHM 11.1.0 cPanel 11.3.11-E12180
    The latest current tree I see is 11.2.11?
    (Also I have CentOS 4.5)


    Oh and to make matter just a "bit" wore, ssh won't work for some reason. The daemon is running, but every time I try to connect, the connection is refused.
    Though I can run individual commands through a VPS control panel. I can also manage files from there.



    Is there some way I can roll back that update I did today?
    ANY suggestions???
     
    #1 Starcraftmazter, May 20, 2007
    Last edited: May 20, 2007
  2. canfone

    canfone Active Member

    Joined:
    Aug 15, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Montreal
    I am having the same problem

    I am having the same problem when attempting to upgrade to Perl 5.8.8

    At the end of the installation I receive:

    Code:
     
    perlmod--Install done
    Can't locate YAML/Syck.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /scripts/cPScript/DataStore.pm line 11.
    BEGIN failed--compilation aborted at /scripts/cPScript/DataStore.pm line 11.
    Compilation failed in require at /scripts/cPScript/Config.pm line 12.
    BEGIN failed--compilation aborted at /scripts/cPScript/Config.pm line 12.
    Compilation failed in require at /scripts/cPScript/cPanelFunctions.pm line 19.
    BEGIN failed--compilation aborted at /scripts/cPScript/cPanelFunctions.pm line 19.
    Compilation failed in require at /scripts/magicloader line 9.
    BEGIN failed--compilation aborted at /scripts/magicloader line 9.
    
    I think it has something to do with the GCC compiler. This is a Virtuozzo VPS running Fedora 4.
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider


    /scripts/perlinstaller --force YAML::Syck
     
  4. Starcraftmazter

    Starcraftmazter Well-Known Member

    Joined:
    May 5, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I wish I could do that, but I can't due to the ptys error ><
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Downgrade cPanel via WHM then. Seems your problems are related to the upgrade of course. Sticking with EDGE isn't going to get any easier.
     
  6. Starcraftmazter

    Starcraftmazter Well-Known Member

    Joined:
    May 5, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I'd love to - please tell me how :D

    Also, this is what /dev looks like. Seems to me, it's missing 50 things >_>
    http://img520.imageshack.us/img520/8190/screenshotjj8.png
     
Loading...
Similar Threads - YAML Erorr Ptys
  1. MrNorbertPL24
    Replies:
    2
    Views:
    824
  2. EatTheDog
    Replies:
    1
    Views:
    246

Share This Page