The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yet another awstats & analog question.

Discussion in 'General Discussion' started by wadearnold, Jun 10, 2003.

  1. wadearnold

    wadearnold Well-Known Member

    Joined:
    Jan 13, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    I have an account that is a little over three weeks old. It does not have a analog or awstats directory in the /home/user/tmp directory. WHM is configured to run stats for all three stats programs. Webalizer runs just fine but does not have the ftp stats. I tried running everything that is in crontab, runlogsnow, runweblogs but nothign has seemed to work. For the analog link I am just not seeing any months. For the awstats part I get the following error :

    Error: Couldn't open config file "awstats.yourxpressions.com.conf" nor "awstats.conf" : No such file or directory

    There is no directory so this can be expected. Is there anyway that I can run an installation of awstats or force it run manually? thanks for all of your help.

    Cheers;
    wade

    cPanel.net Support Ticket Number:
     
  2. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Don't know how cPanel works with Awstats, but for awstats you need the awstats.domainname.conf file .

    Check this:
    locate awstats.pl
    locate awstats.domainname.conf
    ./awstats.pl -config=domainname -update
    DO NOT use the full domain name for config it should be the middle name e.g. if the file is awsats.mydomain.conf then it should be
    ./awstats.pl -config=mydomain -update

    Hope this helps.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page