Arkaos

Member
Jan 6, 2005
22
0
151
Edinburgh, Scotland
Hi Guys,

I was recently playing about with cpanel and generating its on ssl certs from within cpanel before i buy a proper one.

I have installed the key crt and csr and all seems good.

When i go to https://mydomainname.net it comes up with the error connection interrupted.

I have checked apf and 443 is enabled on both inbound and outbound.

The virtualhost in httpd.conf has nothing about my domain being enabled for SSL which im sure it has to.

SSL is deffo enabled as i use ssl for whm which works fine.

# ps -ef | grep stunnel
cpanel 28078 1 0 05:49 ? 00:00:00 /usr/bin/stunnel-4.15local /usr/local/cpanel/etc/stunnel/default/stunnel.conf.run


Any ideas guys?
 

Arkaos

Member
Jan 6, 2005
22
0
151
Edinburgh, Scotland
forgot to add this is whats in my httpd.conf

Also do u have to add ssl certs from whm or can users do it within cpanel like i have done in this instance?

PHP:
<VirtualHost 84.18.x.x>
ServerAlias mydomain.net
ServerAdmin [email protected]
DocumentRoot /home/rtm/public_html
BytesLog domlogs/mydomain.net-bytes_log
ServerName www.mydomain.net

<IfModule mod_userdir.c>
  Userdir disabled
  Userdir enabled rtm
</IfModule>

<IfModule mod_php4.c>
  php_admin_value open_basedir "/home/rtm:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
  php_admin_value open_basedir "/home/rtm:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>

User rtm
Group rtm
CustomLog /usr/local/apache/domlogs/mydomain.net combined
ScriptAlias /cgi-bin/ /home/rtm/public_html/cgi-bin/
</VirtualHost>
 

jackie46

BANNED
Jul 25, 2005
537
0
166
In all the years we have been running cpanel i could never understand how people had SSL issues. Once its installed its done! Nothing more to do. I have never had a SSL issue thats one issue we have never had. How could you screw up the installation?
 

jackie46

BANNED
Jul 25, 2005
537
0
166
Installing thought the user control panel does not work and never has. We have all SSL disabled at the user level via feature manager. It should be installed as root via WHM only.