The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

You are not using a utf-8 language file.

Discussion in 'General Discussion' started by rligg, Nov 28, 2007.

  1. rligg

    rligg Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    In the File Manager I get the following notice in RED.

    You are not using a utf-8 language file. You should not save utf-8 data or you will get corrupted results. Click here to change your language file.


    If I change my language file, I get no more warning. However I do not want others to have to do this. Can someone please explain what I need to do so this does not happen to new accounts?
     
  2. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I had a customer mention this to me again tonight. This is confusing to customers. Anyone else see this, or know why this is happening?

    “You are not using a utf-8 language. You should not save utf-8 data or you will get corrupted results. Click here to change your language.”

    - Scott
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    If you transmit utf-8 data and you aren't using a utf-8 language file it will get downgraded to the character set that your are using. If you are just transmitting english/latin characters this probably isn't a problem. However if you send a utf-8 encoded file with non-latin characters you are going to end up with a mess.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    To prevent this message from appearing, switch your language, in Change Language, to a -utf8 variety. The non-English, non-European languages are UTF8 already.
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Thanks for the info, guys. Unfortunately, this is information overload for my customers. One of the values of cPanel is that it makes difficult tasks easy for customers. This is not an easy "error" for customers to understand, as evidenced by the complaints/support tickets I am receiving.

    Do you mean that there is something I can do in WHM to stop this from occurring in all customer accounts? Or is this what I would tell a customer on how to fix it? If the latter, maybe I could include it in my "welcome instructions". Still, this is not very "cPanel" like to throw up a geeky error message and not guide the customer though solving the problem or explain it in laymen's terms.

    Really... seriously... how many of you actually know what UTF-8 is? How many of your customers know? :)

    - Scott
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I know whenever I encounter this error on a system I'm merely an end-user on, I can just click a link in the message and everything is fixed.

    You can stop this message from appearing by setting your users to use a UTF-8 language file. To do this for many accounts simultaneously go to WHM -> Multi-Account Functions -> Modify/Upgrade Multiple Accounts and halfway down that page, on the right you will see a search box. Clear the contents of the text box and click Select Matching Users. This will select all users in the list. Now scroll do the bottom of the page. For language, if you use the default english file, change it to english-utf8.

    Now your users will already be using a UTF-8 language file and thus will never see this message unless they are a reseller and change it.
     
  7. rligg

    rligg Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    So how to set english-utf8 as default language file?
     
  8. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    But you UNDERSTAND the error, so you feel safe in clicking the link. The customers are opening tickets because they have no idea what the error means and they are afraid of clicking when they don't know what will happen. I am glad they are cautious!

    But this will fix existing customers... what about the next new customer I set up? Is there a way to have this set by default to be english-utf8, so this problem goes away? :)

    Thanks!

    - Scott
     
  9. rligg

    rligg Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    Yes this is what I am asking as well.
     
  10. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The only way to have this happen during account creation, at this point in time, is to use on of the various API/Hooks to automate the change during account creation.

    EDIT:
    You might be able to add the following file to your cpanel3-skel directory, which will be copied to the user's homedir during account setup:

    Filename: .lang
    File Contents:
     
    #10 cPanelKenneth, Feb 1, 2008
    Last edited: Feb 1, 2008
  11. rligg

    rligg Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    That's crazy.
     
  12. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Hey, good idea! This will work great! I see from an account I was testing on, that a .lang file was created, with "english-utf8" inside, in the user's root level of his home directory.

    I've already copied this file into the /root/cpanel3-skel/ directory... will see how it goes... I am pretty sure this is the solution I was looking for... thanks for the idea!

    - Scott
     
  13. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I have put a Feature Request into the cPanel Bugzilla, Bug 6327

    If you'd like to add your comments to this request, or to vote for it, see this link:

    http://bugzilla.cpanel.net/show_bug.cgi?id=6327

    Bugzilla Bug 6327
    File Manager UTF-8 Error is too confusing for end users


    As you are aware, cPanel puts powerful web hosting controls in the hands of the
    average user. cPanel does this in a very user-friendly way.

    However, cPanel is providing a VERY confusing error message to our users, and
    the users are concerned about the error, and opening up Support Tickets with
    our hosting company, because they don't know what is going on.

    The error occurs in the new cPanel 11 File Manager, when the user selects a
    file and attempts to Edit it. The error is as follows (in BOLD and RED)

    "You are not using a utf-8 language. You should not save utf-8 data or you will
    get corrupted results. Click here to change your language."

    I have been involved in computing since 1982, and I have absolutely no idea
    what UTF-8 is. There is no way our average cPanel user is going to know what
    you are talking about here.

    Can you soften this message, and have a link to really explain the problem and
    what the user needs to do, to solve it, in laymen's terms?

    I would also like to see the language file be a part of the package, so that
    when I set up a new hosting account, english-utf8 can be chosen by default,
    which will eliminate this error.

    Per the thread mentioned above, there are some good instructions for adding the
    .lang file to the Skeleton, and I am doing that for now.... seems to be working
    fine.

    Thanks for listening!

    - Scott
     
  14. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Cpanel is throwing up this error message when customers try to add / edit an auto responder. Customer logs into cpanel - clicks auto responder then clicks the "Add" button - this error appears at the top of the page, before they have entered anything...

    You are not using a utf-8 language file. You should not save utf-8 data or you will get corrupted results.
    Click here to change your language file.

    Any ideas on what might cause that ? Customer is using the standard english language file.
     
  15. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The message is simply a warning that extended characters (e.g. characters with certain diacritics; characters outside the character set) can be double-encoded, thus corrupting the data. To rectify this, have the user change the language to english-UTF8. The default English language file uses the latin1 (ISO-8859-1) encoding.
     
  16. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    By default, cPanel uses the english(sic.) language file instead of english-utf8. Since the user isn't using a UTF-8 language file, the cPanel interface displays a message warning of possible data loss as a result of not using a UTF-8 character encoding (caused by not using a UTF-8 language file).

    I would recommend setting your users who are using english(sic.) to use english-utf8 instead. Here is a thread with information on how to change the default language file:

    http://forums.cpanel.net/showthread.php?t=73476
     
  17. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I had opened a ticket on this on Jan 31, 2008 (cPanel Ticket #235225), and it was referred to the cPanel designers. One of the designers assured me that this was being looked into. Here is the last comment on my ticket:

    So, I am hopeful this will be resolved in the near future. :)

    - Scott
     
  18. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Ok thats good. It is a prime example of cpanel thinking like developers and letting that thinking translate into their interface design, instead of looking at it from the end - user point of view.

    Personally, I dont see why there should be ANY warnings about UTF-8. If the customer isnt using a UTF-8 language then leave them alone. They wont know what UTF-8 is and they certainly wont have any interest in using it.

    Heres what a customer does....

    1. They click the button to add an auto - responder
    2. They type stuff in the box
    3. They submit it

    In 99.999% of cases, thats all they do and its all they want to do - nothing more.

    Adding in a warning in red just for the 0.001 % of people, the uber geeks out there who may wish to use UTF-8 is only going to piss off the regular customers who generally need spoon feeding in the first place.

    You should either make the languages UTF-8 or not - why give a choice when 99% of the population have no idea what UTF-8 is anyway ?

    Its fine you recommending that we set languages to UTF-8 but there is no easy way of setting this for all customers is there ? If you say its best to use UTF-8 - then why not allow it to be default, instead of having to mess around with the cpanel3-skel stuff ?
     
  19. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  20. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    And then they open a support ticket with you because the auto-responder/code editor/forwarder/whatever corrupted their data because their cPanel was configured to use the english (the non-UTF-8 variant) character set, but were attempting to add Swedish characters to their signature (because their last name is Swedish and has the special characters). Characters which are outside the ISO-8859-1 encoding (AKA latin1, which is what the non-UTF-8 english language file uses).

    If we had a time machine and could go back 20 years or so, all this would already be solved and no one would have to even know about this stuff.

    You are correct that no one should have to deal with such issues. But reality dictates otherwise.
     
Loading...

Share This Page