You can change the default DNS entry of Webmail?

Quickfast

Registered
Feb 21, 2011
3
0
51
You can change the default DNS entry of Webmail?

When adding a domain, cPanel automatically creates entries for:

cpanel 14400 IN A xxx.xxx.xxx.xxx
whm 14400 IN A xxx.xxx.xxx.xxx
webmail 14400 IN A xxx.xxx.xxx.xxx
webdisk 14400 IN A xxx.xxx.xxx.xxx

It happens that we need to change the entry "webmail" type "A " to type "CNAME" to point to a domain. Is it possible?

What we need is: webmail 14400 IN CNAME mail.01.domain.com.

Note: This is not possible by editing the "Edit Zone Templates".

Appreciate any help.
 
Last edited:

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
38
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

You would need to remove the webmail proxy subdomain entirely and then hard-code the subdomain in the WHM > Edit Zone Templates file. Simply because the entry doesn't exist in that file doesn't mean you cannot create a hard-coded entry. The issue here is that the existing entries stem from having enabled WHM > Tweak Settings > Proxy subdomain creation:

Automatically create cpanel, webmail, webdisk and whm proxy subdomain DNS entries for new accounts. When this is initially enabled it will add appropriate proxy subdomain DNS entries to all existing accounts. (Use /scripts/proxydomains to reconfigure the DNS entries manually)
To remove the existing proxy subdomains, you would use:

Code:
/scripts/proxydomains remove --subdomain=webmail
Then you would need to hard-code the webmail CNAME into the WHM > Edit Zone Templates files and manually add the entry into any already existing zones.

In all actuality, you should simply remove the Proxy Subdomains entirely and hard code all 4 of them in the zone template, because any new domains will try to create that webmail entry due to having enabled that option. If you want to remove all 4 of them entirely, you'd run:

Code:
/scripts/proxydomains remove
Then hard-code the 4 proxy subdomains you want with the CNAME for the webmail one, and uncheck the Tweak Setting.