You cannot convert all accounts to PHP-FPM error

ferdinant40

Member
Oct 3, 2018
6
1
3
Netherlands
cPanel Access Level
Website Owner
Hi,

I'm having problems to get PHP-FPM enabled. We use php 5.6 only and I did install the right php module I believe: "php56-php-fpm"

Code:
apache24
apr
apr-devel
apr-util
apr-util-devel
apr-util-ldap
brotli
config
config-runtime
cpanel-tools
devel
documentroot
libcurl
libmcrypt
libnghttp2
libtidy
libxml2
mod_authn_anon
mod_authn_socache
mod_bwlimited
mod_cache
mod_cache_disk
mod_cgid
mod_charset_lite
mod_deflate
mod_expires
mod_headers
mod_ldap
mod_mpm_worker
mod_proxy
mod_proxy_fcgi
mod_proxy_http
mod_proxy_wstunnel
mod_ssl
mod_suexec
mod_suphp
nghttp2
openssl
php-cli
php-cli-lsphp
php56
php56-libc-client
 php56-pear
php56-php-bcmath
php56-php-calendar
php56-php-cli
php56-php-common
php56-php-curl
php56-php-devel
php56-php-exif
php56-php-fileinfo
php56-php-fpm
php56-php-ftp
php56-php-gd
php56-php-gettext
php56-php-iconv
php56-php-imap
php56-php-litespeed
php56-php-mbstring
php56-php-mcrypt
php56-php-mysqlnd
php56-php-pdo
php56-php-posix
php56-php-process
php56-php-pspell
php56-php-soap
php56-php-sockets
php56-php-tidy
php56-php-xml
php56-php-zendguard
php56-php-zip
php56-runtime
php56-scldevel
profiles-cpanel
tools
When I go to the MultiPHP Manager it says:

"You cannot convert all accounts to PHP-FPM. You do not have the PHP-FPM package for your system’s default PHP version installed."

I do not understand what I'm missing to get this going.

Best Wishes
 

ferdinant40

Member
Oct 3, 2018
6
1
3
Netherlands
cPanel Access Level
Website Owner
Hi,

When i check from the commaned line the php module with: php -i
I see the configure command does not have php-fpm as module enabled. Might this be the reason for not being able to activate php-fpm?

Code:
Configure Command =>  './configure'  '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/opt/cpanel/ea-php56/root/usr' '--exec-prefix=/opt/cpanel/ea-php56/root/usr' '--bindir=/opt/cpanel/ea-php56/root/usr/bin' '--sbindir=/opt/cpanel/ea-php56/root/usr/sbin' '--sysconfdir=/opt/cpanel/ea-php56/root/etc' '--datadir=/opt/cpanel/ea-php56/root/usr/share' '--includedir=/opt/cpanel/ea-php56/root/usr/include' '--libdir=/opt/cpanel/ea-php56/root/usr/lib64' '--libexecdir=/opt/cpanel/ea-php56/root/usr/libexec' '--localstatedir=/opt/cpanel/ea-php56/root/usr/var' '--sharedstatedir=/opt/cpanel/ea-php56/root/usr/com' '--mandir=/opt/cpanel/ea-php56/root/usr/share/man' '--infodir=/opt/cpanel/ea-php56/root/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/opt/cpanel/ea-php56/root/etc' '--with-config-file-scan-dir=/opt/cpanel/ea-php56/root/etc/php.d' '--disable-debug' '--with-pic' '--enable-rpath=/opt/cpanel/ea-php56/root/usr/lib64' '--without-pear' '--with-bz2' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-vpx-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl=/opt/cpanel/ea-openssl' '--with-openssl-dir=/opt/cpanel/ea-openssl' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets' '--with-kerberos' '--enable-shmop' '--with-libxml-dir=/opt/cpanel/ea-libxml2' '--enable-xml' '--with-system-tzdata' '--with-mhash' '--libdir=/opt/cpanel/ea-php56/root/usr/lib64/php' '--enable-pcntl' '--enable-opcache' '--with-imap=shared,/opt/cpanel/ea-php56/root/usr' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-t1lib=/usr' '--with-gd=shared' '--with-gmp=shared' '--enable-calendar=shared' '--enable-bcmath=shared' '--with-bz2=shared' '--enable-ctype=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-tcadb=/usr' '--enable-exif=shared' '--enable-ftp=shared' '--with-gettext=shared' '--with-iconv=shared' '--enable-sockets=shared' '--enable-tokenizer=shared' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--enable-mysqlnd=shared' '--with-mysql=shared,mysqlnd' '--with-mysqli=shared,mysqlnd' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--enable-dom=shared' '--with-pgsql=shared' '--enable-simplexml=shared' '--enable-xml=shared' '--enable-wddx=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-curl=shared,/opt/cpanel/libcurl' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,mysqlnd' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-sqlite3=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--without-readline' '--with-libedit' '--with-pspell=shared' '--enable-phar=shared' '--with-mcrypt=shared,/opt/cpanel/libmcrypt' '--with-tidy=shared,/opt/cpanel/libtidy' '--with-mssql=shared,/opt/cpanel/freetds' '--with-pdo-dblib=shared,/opt/cpanel/freetds' '--enable-sysvmsg=shared' '--enable-sysvshm=shared' '--enable-sysvsem=shared' '--enable-shmop=shared' '--enable-posix=shared' '--with-unixODBC=shared,/usr' '--enable-intl=shared' '--with-icu-dir=/usr' '--with-enchant=shared,/usr' '--with-recode=shared,/usr' '--enable-fileinfo=shared' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'target_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-O2 '-g' '-pipe' '-Wall' '-Wp,-D_FORTIFY_SOURCE=2' '-fexceptions' '-fstack-protector' '--param=ssp-buffer-size=4' '-m64' '-mtune=generic' '-fno-strict-aliasing' '-Wno-pointer-sign'' 'CXXFLAGS=-O2 '-g' '-pipe' '-Wall' '-Wp,-D_FORTIFY_SOURCE=2' '-fexceptions' '-fstack-protector' '--param=ssp-buffer-size=4' '-m64' '-mtune=generic''
Best Wishes
 
Last edited by a moderator:

Jarvis421

Member
Nov 20, 2018
15
2
3
Kochi, India
cPanel Access Level
Root Administrator
Hi,

Can you check your system's default PHP version and ensure it has php-fpm package installed? You should be able to check system's default PHP version from MultiPHP Manager in WHM.

Does your server has CloudLinux installed?
 

ferdinant40

Member
Oct 3, 2018
6
1
3
Netherlands
cPanel Access Level
Website Owner
Hi,

The default version of php is PHP 5.6 (ea-php56). Its also the only php version we have installed.
Easyapache4 says php56-php-fpm is installed as module.
From the command line yum do confirms ea-php56-php-fpm-5.6.39-1.1.2.cpanel.x86_64 already installed
Also in the WHM admin i can restart the php-fpm service and its up and running.

But this command: /opt/cpanel/ea-php56/root/usr/bin/php -i
Tells the php-fpm module has not been enabled during compiling.

Maybe this is the reason MultiPHP Manager is complaining about it not being installed?

We do not have CloudLinux installed.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello @ferdinant40,

In WHM >> MultiPHP Manager, can you you verify what appears under "System PHP Version"? Also, can you post the output from the following commands?

Code:
cat /usr/local/cpanel/version
rpm -qa|grep fpm
rpm -qa|grep ea-php
Thank you.
 

ferdinant40

Member
Oct 3, 2018
6
1
3
Netherlands
cPanel Access Level
Website Owner
Hi Michael,

Below is all the information you requested:

----

MultiPHP Manager / System PHP Version: PHP 5.6 (ea-php56)

----

cat /usr/local/cpanel/version
11.76.0.14

----

rpm -qa|grep fpm
ea-php56-php-fpm-5.6.39-1.1.2.cpanel.x86_64

----

rpm -qa|grep ea-php

ea-php56-php-common-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-fileinfo-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-posix-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-mcrypt-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-mbstring-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-mysqlnd-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-soap-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-devel-5.6.39-1.1.2.cpanel.x86_64
ea-php56-pear-1.10.1-12.12.27.cpanel.noarch
ea-php56-php-exif-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-zip-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-litespeed-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-iconv-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-process-5.6.39-1.1.2.cpanel.x86_64
ea-php-cli-0.2.0-7.7.1.cpanel.x86_64
ea-php56-php-sockets-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-xml-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-pdo-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-curl-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-gettext-5.6.39-1.1.2.cpanel.x86_64
ea-php56-runtime-5.6.39-1.1.1.cpanel.x86_64
ea-php56-php-tidy-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-pspell-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-fpm-5.6.39-1.1.2.cpanel.x86_64
ea-php-cli-lsphp-0.2.0-7.7.1.cpanel.x86_64
ea-php56-php-zendguard-3.3-7.7.105.cpanel.x86_64
ea-php56-php-gd-5.6.39-1.1.2.cpanel.x86_64
ea-php56-build-5.6.39-1.1.1.cpanel.x86_64
ea-php56-5.6.39-1.1.1.cpanel.x86_64
ea-php56-php-calendar-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-cli-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-imap-5.6.39-1.1.2.cpanel.x86_64
ea-php56-scldevel-5.6.39-1.1.1.cpanel.x86_64
ea-php56-libc-client-2007f-13.13.4.cpanel.x86_64
ea-php56-php-ftp-5.6.39-1.1.2.cpanel.x86_64
ea-php56-php-bcmath-5.6.39-1.1.2.cpanel.x86_64

----

Best Wishes
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,247
363
Hello @ferdinant40,

Can you open a support ticket so we can take a closer look at the affected system? You can post the ticket number here and we'll link this thread to it.

Thank you.