Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

You cannot install more than one script error

Discussion in 'General Discussion' started by anhnn123, Jun 22, 2018.

  1. anhnn123

    anhnn123 Registered

    Joined:
    Jun 16, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    hcm
    cPanel Access Level:
    Website Owner
    WHM did just update a few day ago, and I'm now using cPanel 11.32.2 (build 15).

    Today, I created a new account for the first time after the upgrade. The client tried to install Templates Express via Fantastico, but received an error that "You cannot install more than one script in the root directory of a domain." Fantastico does not show any prior installations, though.

    After mentioning this error to me, I tried to FTP in to see what was existing. I'm surprised, though, to find that there's no longer a /www/ or /public_html/ directory! All I have is:

    /.cpan/
    /.cpanel/
    /.cpcpan/
    /.fantasticodata/
    /.htpasswds/
    /.HttpRequest/
    /.MirrorSearch/
     
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    779
    Likes Received:
    274
    Trophy Points:
    113
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    cPanel 11.32 went End Of Life August 20, 2013 and has probably received no security or feature updates since that date.

    See Impending EOL, 11.32 | cPanel Newsroom

    It is entirely possible that the Fantastico installer, built for the latest version of cPanel, has not worked on your out-of-date version and may have caused some unintended file corruption.

    The latest release version of cPanel at time of writing is 11.70.0 (build 51) now known as just 70.0.51

    You are marked as being a website owner, you may want to ask your web host why they are running such an out-of-date cPanel installation (If I had to guess, it would be that the server was built on CentOS 4 and cPanel 11.32 was the last version to support that OS)

    Perhaps you should consider moving your website to a web host that offers a more up-to-date hosting environment, or if you are actually the web server owner/administrator, you should consider migrating to a newer server/OS/cPanel-WHM .

    Given that you say this is a NEW account - you may want to try deleting it and then re-creating it to get the full file structure back.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #2 rpvw, Jun 23, 2018
    Last edited: Jun 23, 2018
    cPanelLauren likes this.
  3. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,721
    Likes Received:
    186
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    As mentioned by @rpvw this version of cPanel is long since EoL and is not supported by cPanel at this time.


    This shows only that you have hidden directories. Are you able to access the server via SSH? If so can you provide the output of:

    Code:
    ls -lah /home/$user/
    What I would assume is that the ownership of the directory is incorrect, though if this is not the case you may need to restore the site from the most recent backup.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice