The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

You don't have permission to access /on this server.

Discussion in 'General Discussion' started by edesignway, Jan 8, 2004.

  1. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Good Afternoon,

    I seem to be having a very strange problem with one of my clients. When you type in his domain or IP it comes up with

    You don't have permission to access / on this server. (Or any other file)

    I have checked every imaginable setting and permissions I can think of. I even ran /scripts/fixeverything in hopes it might help. No such luck.

    However if I create an index.html page as root, it loads.

    Any help would be greatly appreciated!

    Thank you,
    Timothy Sheehan
     
  2. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    This is what the Apache error log has to say:

    [Thu Jan 8 16:07:22 2004] [error] [client 64.175.xxx.xxx] (13)Permission denied: file permissions deny server access: /home/user/public_html/index.htm
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    cd /home

    - find the username for the directory with the problem

    chgrp nobody username

    Was this a recent transfer? They are usually transferred as the group owner 'nobody' and need to stay that way -- until Cpanel updates the group ownership.
     
  4. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Rob,

    Thanks for the post. This isn't a recent transfer, the site was woring fine for several days and then poof, no more.

    I ran the ls - l command on the /home/user dir and it returned

    /home/user
    drwx--x--x 15 user user 4096 Jan 8 15:52 user/

    For the public_html
    drwxr-x--- 37 user nobody 4096 Jan 8 15:52 public_html/

    For the index.htm file
    -rwxr-x--- 1 user user 4731 Jan 8 15:52 index.htm



    Regards,
    Timothy Sheehan
     
  5. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Also, is it safe to change his group to nobody?
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Your post helped to point out my mistake, as it should be the 'public_html' dir that is user.nobody - thanks. ;)

    For the index.htm file
    -rw-r--r-- 1 user user 4731 Jan 8 15:52 index.htm

    should work. Is it just the index file having problems?
     
  7. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Rob,

    The public_html folder is user.nobody

    All files do not load that are in his public_html dir.

    Tim
     
  8. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I would start with the IP address and work from there. If all DNS settings for the account are correct, give a shot with using:

    /scripts/updatenow; /scripts/upcp; service cpanel stop; service cpanel start

    This will upgrade Cpanel for you and, if that doesn't work, /scripts/fixquotas has been known to help "strange" account problems. Or try it first, your choice.
     
  9. RaveKnights

    RaveKnights Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Some Where Out There!
    Also if you don't mind me adding?

    Did this person install FrontPage extensions? It could be that the .htaccess file is corrupted. Uninstall the extension and delete all .htaccess files than re-install the extensions.

    even if they didn't install the FP extensions delete the .htaccess file to see if it helps.
     
  10. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Rob,

    I tried what you mentioned, it appears that didn't fix the problem ;(

    RaveKnights
    Earlier today I tried removing the FP ext. and deleting the .htaccess, however that didn't fix the problem either.

    Thanks for your ideas, please send me more if you can think of any!

    Regards,
    Timothy Sheehan
     
  11. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    After talking with the client I asked if I can recreate the account to see if that would solve the problem, which it did. Though I am very curious as to what can cause something like this.

    Thanks for your help!
    Timothy Sheehan
     
  12. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Are the settings for 'public_html' dir. and the index file, same as what was mentioned above?
     
  13. edesignway

    edesignway Well-Known Member

    Joined:
    Dec 4, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Yes, all permissions that I had before the recreation of the account are all the same as after the recreation of the account.
     
Loading...

Share This Page