Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED You must upgrade to Litespeed for cPanel update

Discussion in 'General Discussion' started by gildas, Jan 9, 2018.

Tags:
  1. gildas

    gildas Active Member

    Joined:
    Mar 30, 2017
    Messages:
    28
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Paris
    cPanel Access Level:
    Root Administrator
    Hello,

    the update of my cpanel currently in version 66.0.34 to the latest available version does not take place.
    In the logs the following error is present:
    [2018-01-09 15:36:23 +0100] W NOTE: A system upgrade was not possible due to the following blockers:
    [2018-01-09 15:36:23 +0100] W [FATAL] - You must upgrade to Litespeed "5.2.1 build 2 or later", in order to upgrade to the next version of cPanel & WHM.

    the Litespeed service is no longer active on this server / cpanel.
    Do you know how to solve this error?

    Best Regards,
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,353
    Likes Received:
    1,855
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This is noted in the cPanel 68 Release Notes:

    You will need to update LiteSpeed, or completely uninstall it in order for the cPanel update to proceed:

    litespeed_wiki:cpanel:whm-lsws-plugin-uninstall [LiteSpeed Wiki]

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. gildas

    gildas Active Member

    Joined:
    Mar 30, 2017
    Messages:
    28
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Paris
    cPanel Access Level:
    Root Administrator
    Hello,

    Thank you for your reply.
    However, the order:
    /usr/local/lsws/admin/misc/cp_switch_ws.sh apache
    returns the following error:
    [ERROR] cPanel environment detected, but LiteSpeed WHM plugin not installed

    I was able to launch the command:
    /usr/local/lsws/admin/misc/uninstall.sh
    that offers the uninstall of LiteSpeed Web Server

    but at the CPANEL update, the error:
    W [FATAL] - You must upgrade to Litespeed "5.2.1 build 2 or later", in order to upgrade to the next version of cPanel & WHM

    is still present (a reboot of the machine was performed) between these two actions (uninstall.sh and update)

    Best Regards,
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,353
    Likes Received:
    1,855
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    What method did you use to originally install and uninstall the LiteSpeed plugin? If it wasn't uninstalled using traditional methods, then you should install it again, and then uninstall it using the URL referenced in my last response. Let us know if that helps.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. gildas

    gildas Active Member

    Joined:
    Mar 30, 2017
    Messages:
    28
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Paris
    cPanel Access Level:
    Root Administrator
    Hello,

    The re-installation of litespeed and its desastallation solved this problem.

    I thank you for your return.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,353
    Likes Received:
    1,855
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see that helped. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice