Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED You Need Super Privileges for this operation

Discussion in 'Database Discussions' started by warmwhisky, Dec 21, 2017.

  1. warmwhisky

    warmwhisky Member

    Joined:
    Nov 13, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Swaziland
    cPanel Access Level:
    Root Administrator
    Regarding the below quote. Please can you explain how and where I do this?

    I have logged in to SSH as root then executed "mysql -uroot -p"
    then executed the below, but it still doesn't work. I have changed the dummy text to my credentials and db. The error I receive is
    Incorrect usage of DB GRANT and GLOBAL PRIVILEGES

    I have also tried this
    Code:
    GRANT ALL ON DB_NAME.* TO 'USER'@'HOST' IDENTIFIED BY 'PASSWORD' WITH GRANT OPTION;
    But it says zero rows effected

    I have also tried this
    Code:
    GRANT SUPER ON DB_NAME.* TO USER@'localhost' IDENTIFIED BY 'PASSWORD';
    Again zero row effected

    How do I create and run stored procedures in my app? It works fine on my local copy.


     
    #1 warmwhisky, Dec 21, 2017
    Last edited: Dec 22, 2017
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    582
    Likes Received:
    177
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
  3. warmwhisky

    warmwhisky Member

    Joined:
    Nov 13, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Swaziland
    cPanel Access Level:
    Root Administrator
    My mistake,

    I already had the permissions to create procedures. But when I exported my procedure from my local machine I picked up a DEFINER that had an incorrect user "root" attached. I removed the DEFINER and the procedure was created successfully.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see you were able to solve the issue. Thank you for sharing the solution.
     
Loading...

Share This Page