Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Discussion in 'EasyApache' started by fino47, Aug 2, 2017.

  1. fino47

    fino47 Member

    Joined:
    Nov 26, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mexico
    cPanel Access Level:
    Website Owner
    After migration to easyapache 4 i get this error on all my wordpress sites.
     
  2. Tearabite

    Tearabite Well-Known Member

    Joined:
    Nov 28, 2010
    Messages:
    76
    Likes Received:
    11
    Trophy Points:
    58
    Location:
    Southern California
    cPanel Access Level:
    Root Administrator
    I had this same issue - check your PHP and make sure the MySQL extension is enabled for your version of PHP.. It's a Simple fix.
     
    #2 Tearabite, Aug 2, 2017
    Last edited: Aug 2, 2017
  3. Eminds

    Eminds Well-Known Member

    Joined:
    Nov 10, 2016
    Messages:
    267
    Likes Received:
    20
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    recompile php from easy apache. login to whm with root >> click on easy apache >> select the active profile and click on customize >> under php extension you should see mysql extension >> enable / install it >> and you are done.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,881
    Likes Received:
    89
    Trophy Points:
    78
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    The error suggests that the PHP that the website is using is missing the extension required for the Wordpress website to connect to the database, so installing this missing module is the resolution for the issue you are facing..

    In addition to the Easyapache execution, you can also do that from the shell where you can execute the below command on your cPanel server, which will the required module for you..

    # yum install ea-php*-mysql*
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    825
    Likes Received:
    300
    Trophy Points:
    113
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    @fino47

    If you are a website owner with no root administrative access to WHM or to a root shell, the advice, so far, given in this thread will be of no use to you directly.

    Check in your cPanel php.ini config that the extensions are not disabled (in which case you can simply enable them)

    If you do not see the extensions you need, you will need to contact your hosting provider, and ask them to recompile Apache with the required extensions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #5 rpvw, Aug 3, 2017
    Last edited: Aug 3, 2017
    cPanelMichael likes this.
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice