Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
We've had clients report to us that their sites are now displaying the "Your PHP installation appears to be missing the MySQL extension which is required by WordPress" error.

Upon checking we can see that they are running the latest WordPress version 5.7.2, PHP version 7.4.20 and WHM > MultiPHP selected alt-7.4php which I believe is using Cloudlinux.

Our Server: CLOUDLINUX 7.9 [web1] v94.0.11


I'm not certain if this is related but a lot sites reporting screwy behaviour have this now in their error logs
PHP Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /home/xxxxxxx/xxxxx/wp-includes/Requests/Transport/cURL.php on line 150
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,068
775
313
cPanel Access Level
Root Administrator
Hey there! We have an article about the MySQL issue here:


Can you check that out and see if that resolves your issue?

I don't believe the second issue is related, but you aren't the only user that has experienced that issue with the plugin: PHP 7.4 update breaking because of WPBaker - WordPress Websites For Businesses, Artists, Bloggers Shops And More
 

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
It turns out our Server provider performed an unscheduled update jumping us from CloudLinux 7.7 v84 to CloudLinux 7.9 v94.
Before the update we had access to the Plugin: LVE Manager - PHP selector in cPanel, after the update it was missing.
In this particular case the PHP version for the site was still set to alt-72php, when the cPanel PHP Selector was restored we changed it in cPanel and the site loaded correctly.


As for the PHP Fatal error: [snuffleupagus][disabled_function] issue, we don't have any sites running the WPBakery plugin.
 

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
We are now seeing this error on WordPress sites using EasyApache ea-74php This includes fresh installations, no plugins or added themes.

PHP Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /home/xxxxxxx/xxxxx/wp-includes/Requests/Transport/cURL.php on line 150

This started after the server was updated from v84 to v94. We have notified the provider that it may be due to curl_setopt being disabled Or the extension snuffleupagus missing Waiting to hear their response.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,068
775
313
cPanel Access Level
Root Administrator
The WPBakery plugin wasn't what I was getting toward in that article, but it was the snuffleupagus configuration that seems to come up in all your errors. Can you run this command on the server and send the result?

Code:
rpm -qa | grep snuffleupagus
 

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
root [/]# rpm -qa | grep snuffleupagus
ea-php74-php-snuffleupagus-0.5.0-5.cloudlinux.x86_64

The host provider has informed us overnight we will need to add code to all our WordPress sites to workaround the problem.
 

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
add_filter( 'https_local_ssl_verify', '__return_true' );

I've been told that adding this code should not be required and may not be the best idea. With over 150 WordPress sites this doesn't appear to be a viable solution.
Not to mention it occurs on fresh installs of WordPress 5.7.2
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,068
775
313
cPanel Access Level
Root Administrator
That's interesting - that code tells a specific plugin to override the default value. More details on that are outlined here:


I did some more research and it looks like this was actually reported to WordPress directly a while back, but is not something they intend to fix:


You may just need to use PHP 7.3 on that site and look for a different plugin that works with more updated versions.
 

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
So a clean install of WordPress v5.7.2 with no plugins aside from the two Askimet and Hello Dolly (included with WP), generates the error. And from now on we need to insert that line into the WordPress functions.php file for every client, new and old, that wants to use php v7.4?
 
Last edited:

SlapHappy

Member
Jul 8, 2014
13
1
51
cPanel Access Level
Reseller Owner
That doesn't sound right to me - every installation of WordPress in the world can't be broken, or this would be a major issue.

Could you open a ticket with our support team so we can check this directly on your system?
Apologies for the delay in responding. I will open the ticket after our server backup completes, which should be tomorrow sometime.
 
  • Like
Reactions: cPRex