The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Your profile has Apache 2.4.16 chosen to build Your currently running apache is Apache 2.4.17

Discussion in 'EasyApache' started by celiac101, Nov 18, 2015.

  1. celiac101

    celiac101 Active Member

    Joined:
    Dec 19, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    I am running Easy Apache 3.x and see Easy Apache 4.x available in my Cpanel control panel, but I've not upgraded because I see many draconian warnings when I start this process.

    That said, my real issue now is that when I check for updates using Easy Apache 3.x I now see this, which I've never seen before:

    Your profile has Apache 2.4.16 chosen to build

    Your currently running apache is Apache 2.4.17

    Also, for a few weeks now I've not seen any updates there for Apache or PHP (I'm running 5.5.30). Here are my questions:
    1. Is Easy Apache 3.x still working and offering me the latest updates?
    2. Should I ignore all of the draconian warning about Easy Apache 4.x might not work at all on my server and still upgrade?
    3. Why would Easy Apache 3.x be offering me an older and lower version of Apache--I've never seen that before?
    Any help would be appreciated.
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    1. Yes. EasyApache 3 is still functioning.
    2. The web stack installed by EasyApache 4 is quite stable. The warnings are about the migration from EasyApache 3 to EasyApache 4. Custom changes tend to cause problems. If you do convert and encounter problems, please don't hesitate to open a support ticket with us so we can resolve any problems, and get your server in a good state.
    3. We downgraded Apache 2.4 to 2.4.16 in both EA3 and EA4 due to a bug introduced in Apache 2.4.17 that cause lots of problems. More information about that change is available here: EasyApache 3.32.4 Released (Apache downgrade!) | cPanel Newsroom
     
  3. celiac101

    celiac101 Active Member

    Joined:
    Dec 19, 2012
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    Thank you Kenneth! In an ideal world such news updates would be pulled directly into the Easy Apache module, so, for example, if I clicked on Easy Apache I'd see such critical news displayed within that module, rather than having to hunt around for answers for weeks. Just a suggestion.
     
  4. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Just a heads up, the EA change log recorded the bug introduced in Apache 2.4.17, you can find the log here: EasyApache Change Log - EasyApache - cPanel Documentation
     
Loading...

Share This Page