The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yum (and rpm?) broken - Who updates the updater?

Discussion in 'General Discussion' started by WindyT, Apr 25, 2009.

  1. WindyT

    WindyT Active Member

    Joined:
    Nov 30, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    The last time that Yum looked like it worked was Apr2. From the yum.log:
    Code:
    Feb 05 05:07:03 Updated: nss-tools - 3.12.2.0-4.el5.centos.x86_64
    Apr 02 05:13:49 Updated: libgcc - 4.1.2-44.el5.i386
    Apr 02 05:13:50 Updated: libgcc - 4.1.2-44.el5.x86_64
    Apr 02 05:14:08 Updated: glibc-common - 2.5-34.x86_64
    Apr 02 05:14:18 Updated: glibc - 2.5-34.x86_64
    Apr 02 05:14:20 Updated: glibc - 2.5-34.i686
    Apr 02 05:14:21 Updated: popt - 1.10.2.3-9.el5.x86_64
    Apr 02 05:14:21 Updated: libstdc++ - 4.1.2-44.el5.x86_64
    Apr 02 05:14:23 Updated: pam - 0.99.6.2-4.el5.x86_64
    Apr 02 05:14:25 Updated: openssl - 0.9.8e-7.el5.x86_64
    Apr 02 05:14:26 Updated: libgomp - 4.3.2-7.el5.x86_64
    Apr 02 05:14:26 Updated: libstdc++ - 4.1.2-44.el5.i386
    Apr 02 05:14:28 Updated: glibc-headers - 2.5-34.x86_64
    Apr 02 05:14:29 Updated: cpp - 4.1.2-44.el5.x86_64
    Apr 02 05:14:30 Updated: pam - 0.99.6.2-4.el5.i386
    Apr 02 05:14:32 Updated: openssl - 0.9.8e-7.el5.i686
    Apr 02 05:14:32 Updated: popt - 1.10.2.3-9.el5.i386
    Apr 02 05:14:35 Updated: glibc-devel - 2.5-34.x86_64
    Apr 02 05:14:37 Updated: gcc - 4.1.2-44.el5.x86_64
    Apr 02 05:14:39 Updated: libstdc++-devel - 4.1.2-44.el5.i386
    Apr 02 05:14:40 Updated: gcc-c++ - 4.1.2-44.el5.x86_64
    Apr 02 05:14:43 Updated: openssl-devel - 0.9.8e-7.el5.i386
    Apr 02 05:14:44 Updated: pam-devel - 0.99.6.2-4.el5.i386
    Apr 02 05:14:44 Updated: glibc-devel - 2.5-34.i386
    Apr 02 05:14:46 Updated: libstdc++-devel - 4.1.2-44.el5.x86_64
    Apr 02 05:14:48 Updated: openssl-devel - 0.9.8e-7.el5.x86_64
    Apr 02 05:14:48 Updated: pam-devel - 0.99.6.2-4.el5.x86_64
    Apr 02 05:14:49 Updated: rpm-libs - 4.4.2.3-9.el5.x86_64
    Apr 02 05:14:50 Updated: rpm - 4.4.2.3-9.el5.x86_64
    Apr 02 05:14:51 Updated: rpm-build - 4.4.2.3-9.el5.x86_64
    Apr 02 05:14:51 Updated: rpm-python - 4.4.2.3-9.el5.x86_64
    
    
    cPanel 11.24.4-R35075 - WHM 11.24.2 - X 3.9
    CENTOS 5.2 x86_64 standard on myserver

    My first symptom was manually trying to update Cpanel, with it hanging.
    CentOS is stuck at 5.2 as well.
    I get no error messages from _any_ yum command from the SSH

    yum --help
    even hangs with no response.

    and the same with
    rpm -qa | grep yum

    I get nothing. It just seems to hang.
    ditto with
    rpm -qa | sort

    I'm guessing I have a corrupt rpm database on top of everything else because of that.

    The server is live with about 90 accounts on it, and it seems to be functioning okay -- it just wont' update.

    Is this a Cpanel support ticket issue?
    A yum install/reinstall issue? If so, is there a guide for a yum reinstall?
    Do I fall back on the Pay Tech Lots Of Money?

    The only search help I've found so far might have to do with a python update messing up something. Thats' why I posted the last of the yum.log above.
    Is there another error log I should be posting for additional information?
    ---

    (I'm always reticent to post problems here, because I search both before and after I post, but since I'm thisclose to putting in a trouble ticket, I'm posting it here first.)
    I'm guessing this broke based on an update; I figure others might have had this happen to them.

    Thanks for any input
     
  2. voip

    voip Member

    Joined:
    Apr 8, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
  3. WindyT

    WindyT Active Member

    Joined:
    Nov 30, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
Loading...

Share This Page