Speedy059

Well-Known Member
Jul 10, 2007
55
1
58
It appears that there were some bad updates or something, as now our cpanel/whm server cannot update itself. Does anyone have some suggestions on how to fix this issue? Yum now gives this error:


--------------------------------------------------------------
[email protected] [/etc/yum.repos.d]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.loosefoot.com
* epel: mirrors.xmission.com
* extras: mirrors.loosefoot.com
* updates: mirror.team-cymru.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package iwl6000-firmware.noarch 0:9.193.4.1-1.el5 set to be updated
---> Package libtalloc.x86_64 0:2.0.1-7.el5 set to be updated
---> Package libtdb.x86_64 0:1.2.1-4.el5 set to be updated
---> Package python-ethtool.x86_64 0:0.6-2.el5 set to be updated
--> Processing Dependency: python(abi) = 2.4 for package: python-ethtool-0.6-2.el5.x86_64
--> Finished Dependency Resolution
Error: Package: python-ethtool-0.6-2.el5.x86_64 (epel)
Requires: python(abi) = 2.4
Installed: python-2.6.5-3.el6_0.2.x86_64 (@updates)
python(abi) = 2.6
Available: python-2.6.5-3.el6.i686 (base)
python(abi) = 2.6
Available: python-2.6.5-3.el6.x86_64 (base)
python(abi) = 2.6
Available: python26-2.6.5-6.el5.x86_64 (epel)
python(abi) = 2.6
You could try using --skip-broken to work around the problem
bandmin-1.6.1-4_newinit.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-4_newinit.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-4_newinit.noarch has missing requires of perl(services.conf)
exim-4.69-30_cpanel_maildir.x86_64 has missing requires of perl(SafeFile)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
--------------------------------------------------------------

Any suggestions on how to fix the yum updates would be helpful. As I believe there are some bad packages now that caused our system to crash.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello :)

It looks like the following custom RPM is installed on your system:

python-ethtool
This is the package that is failing to update due to the requirement of Python 2.4. CentOS 6 (which it appears you are using) comes packaged only with Python 2.6.

You could try removing python-ethtool if it's not required for any custom applications to see if that allows YUM to update.

Thank you.