Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Yum broken after updates?

Discussion in 'General Discussion' started by Speedy059, Oct 22, 2011.

  1. Speedy059

    Speedy059 Well-Known Member

    Jul 10, 2007
    Likes Received:
    Trophy Points:
    It appears that there were some bad updates or something, as now our cpanel/whm server cannot update itself. Does anyone have some suggestions on how to fix this issue? Yum now gives this error:

    root@srv1 [/etc/yum.repos.d]# yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base:
    * epel:
    * extras:
    * updates:
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package iwl6000-firmware.noarch 0: set to be updated
    ---> Package libtalloc.x86_64 0:2.0.1-7.el5 set to be updated
    ---> Package libtdb.x86_64 0:1.2.1-4.el5 set to be updated
    ---> Package python-ethtool.x86_64 0:0.6-2.el5 set to be updated
    --> Processing Dependency: python(abi) = 2.4 for package: python-ethtool-0.6-2.el5.x86_64
    --> Finished Dependency Resolution
    Error: Package: python-ethtool-0.6-2.el5.x86_64 (epel)
    Requires: python(abi) = 2.4
    Installed: python-2.6.5-3.el6_0.2.x86_64 (@updates)
    python(abi) = 2.6
    Available: python-2.6.5-3.el6.i686 (base)
    python(abi) = 2.6
    Available: python-2.6.5-3.el6.x86_64 (base)
    python(abi) = 2.6
    Available: python26-2.6.5-6.el5.x86_64 (epel)
    python(abi) = 2.6
    You could try using --skip-broken to work around the problem
    bandmin-1.6.1-4_newinit.noarch has missing requires of perl(bandmin.conf)
    bandmin-1.6.1-4_newinit.noarch has missing requires of perl(
    bandmin-1.6.1-4_newinit.noarch has missing requires of perl(services.conf)
    exim-4.69-30_cpanel_maildir.x86_64 has missing requires of perl(SafeFile)
    frontpage-2002-SR1.2.i386 has missing requires of

    Any suggestions on how to fix the yum updates would be helpful. As I believe there are some bad packages now that caused our system to crash.
  2. arhs

    arhs Well-Known Member

    Jul 4, 2003
    Likes Received:
    Trophy Points:
    I'm also getting this on centos 6
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    It looks like the following custom RPM is installed on your system:

    This is the package that is failing to update due to the requirement of Python 2.4. CentOS 6 (which it appears you are using) comes packaged only with Python 2.6.

    You could try removing python-ethtool if it's not required for any custom applications to see if that allows YUM to update.

    Thank you.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice