The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yum Error on dedicated server

Discussion in 'General Discussion' started by rohit09, Jan 26, 2013.

  1. rohit09

    rohit09 Well-Known Member

    Joined:
    Dec 10, 2010
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I got yum error on my dedicated server

    Code:
    [root@LH19677 ~]# yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * base: ftp.ines.lug.ro
     * extras: ftp.ines.lug.ro
     * openvz-kernel-rhel5: mirrors.ircam.fr
     * openvz-utils: mirrors.ircam.fr
     * updates: ftp.ines.lug.ro
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package apr.x86_64 0:1.4.6-1 set to be updated
    ---> Package apr-util.x86_64 0:1.4.1-1 set to be updated
    ---> Package aspell-en.x86_64 50:6.0-3 set to be updated
    ---> Package centos-release.x86_64 10:5-9.el5.centos.1 set to be updated
    ---> Package centos-release-notes.x86_64 0:5.9-0 set to be updated
    ---> Package cpio.x86_64 0:2.6-25.el5 set to be updated
    ---> Package crontabs.noarch 0:1.10-11.el5 set to be updated
    ---> Package cyrus-sasl-lib.x86_64 0:2.1.22-7.el5_8.1 set to be updated
    ---> Package device-mapper-multipath.x86_64 0:0.4.7-54.el5 set to be updated
    ---> Package dhclient.x86_64 12:3.0.5-33.el5_9 set to be updated
    ---> Package dhcp.x86_64 12:3.0.5-33.el5_9 set to be updated
    ---> Package diffutils.x86_64 0:2.8.1-16.el5 set to be updated
    ---> Package e2fsprogs.x86_64 0:1.39-35.el5 set to be updated
    ---> Package e2fsprogs-libs.i386 0:1.39-35.el5 set to be updated
    ---> Package e2fsprogs-libs.x86_64 0:1.39-35.el5 set to be updated
    ---> Package file.x86_64 0:4.17-28 set to be updated
    ---> Package gawk.x86_64 0:3.1.5-16.el5 set to be updated
    ---> Package gdbm.x86_64 0:1.8.0-28.el5 set to be updated
    ---> Package glibc.i686 0:2.5-107 set to be updated
    ---> Package glibc.x86_64 0:2.5-107 set to be updated
    ---> Package glibc-common.x86_64 0:2.5-107 set to be updated
    ---> Package gnutls.i386 0:1.4.1-10.el5 set to be updated
    ---> Package gnutls.x86_64 0:1.4.1-10.el5 set to be updated
    ---> Package grub.x86_64 0:0.97-13.10.el5 set to be updated
    ---> Package gtk2.i386 0:2.10.4-29.el5 set to be updated
    ---> Package gtk2.x86_64 0:2.10.4-29.el5 set to be updated
    ---> Package hal.x86_64 0:0.5.8.1-64.el5 set to be updated
    ---> Package httpd.x86_64 0:2.2.23-3 set to be updated
    --> Processing Dependency: httpd-tools = 2.2.23-3 for package: httpd
    --> Processing Dependency: apr-util-ldap for package: httpd
    ---> Package hwdata.noarch 0:0.213.28-1.el5 set to be updated
    ---> Package initscripts.x86_64 0:8.45.42-1.el5.centos.1 set to be updated
    ---> Package iproute.x86_64 0:2.6.18-15.el5 set to be updated
    ---> Package iscsi-initiator-utils.x86_64 0:6.2.0.872-16.el5 set to be updated
    ---> Package kbd.x86_64 0:1.12-22.el5 set to be updated
    ---> Package kernel.x86_64 0:2.6.18-348.1.1.el5 set to be installed
    ---> Package kpartx.x86_64 0:0.4.7-54.el5 set to be updated
    ---> Package kudzu.x86_64 0:1.2.57.1.26-7.el5.centos set to be updated
    ---> Package libgcc.i386 0:4.1.2-54.el5 set to be updated
    ---> Package libgcc.x86_64 0:4.1.2-54.el5 set to be updated
    ---> Package libstdc++.i386 0:4.1.2-54.el5 set to be updated
    ---> Package libstdc++.x86_64 0:4.1.2-54.el5 set to be updated
    ---> Package libtiff.i386 0:3.8.2-18.el5_8 set to be updated
    ---> Package libtiff.x86_64 0:3.8.2-18.el5_8 set to be updated
    ---> Package libuser.x86_64 0:0.54.7-3.el5 set to be updated
    ---> Package libvolume_id.x86_64 0:095-14.29.el5 set to be updated
    ---> Package libxml2.i386 0:2.6.26-2.1.15.el5_8.6 set to be updated
    ---> Package libxml2.x86_64 0:2.6.26-2.1.15.el5_8.6 set to be updated
    ---> Package logrotate.x86_64 0:3.7.4-14 set to be updated
    ---> Package lvm2.x86_64 0:2.02.88-10.el5 set to be updated
    ---> Package lxlighttpd.x86_64 0:1.4.32-1 set to be updated
    ---> Package m2crypto.x86_64 0:0.16-9.el5 set to be updated
    ---> Package mkinitrd.i386 0:5.1.19.6-79.el5 set to be updated
    ---> Package mkinitrd.x86_64 0:5.1.19.6-79.el5 set to be updated
    ---> Package mysql.i386 0:5.0.95-5.el5_9 set to be updated
    ---> Package mysql.x86_64 0:5.0.96-1 set to be updated
    ---> Package mysql-server.x86_64 0:5.0.96-1 set to be updated
    ---> Package nash.x86_64 0:5.1.19.6-79.el5 set to be updated
    ---> Package nspr.i386 0:4.9.1-6.el5 set to be updated
    ---> Package nspr.x86_64 0:4.9.1-6.el5 set to be updated
    ---> Package nss.i386 0:3.13.5-8.el5 set to be updated
    ---> Package nss.x86_64 0:3.13.5-8.el5 set to be updated
    ---> Package pam.i386 0:0.99.6.2-12.el5 set to be updated
    ---> Package pam.x86_64 0:0.99.6.2-12.el5 set to be updated
    ---> Package parted.i386 0:1.8.1-30.el5 set to be updated
    ---> Package parted.x86_64 0:1.8.1-30.el5 set to be updated
    ---> Package pcre.x86_64 0:8.02-1.el5_5.1 set to be updated
    ---> Package perl.x86_64 4:5.8.8-38.el5_8 set to be updated
    ---> Package php.x86_64 0:5.2.17-24 set to be updated
    ---> Package php-cli.x86_64 0:5.2.17-24 set to be updated
    --> Processing Dependency: libevent-1.4.so.2()(64bit) for package: php-cli
    ---> Package php-common.x86_64 0:5.2.17-24 set to be updated
    ---> Package ploop.x86_64 0:1.6-1 set to be updated
    ---> Package ploop-lib.x86_64 0:1.6-1 set to be updated
    --> Processing Dependency: e2fsprogs-resize2fs-static for package: ploop-lib
    ---> Package pm-utils.x86_64 0:0.99.3-14.el5 set to be updated
    ---> Package popt.x86_64 0:1.10.2.3-31.el5 set to be updated
    ---> Package postgresql-libs.i386 0:8.1.23-6.el5_8 set to be updated
    ---> Package postgresql-libs.x86_64 0:8.1.23-6.el5_8 set to be updated
    ---> Package procps.x86_64 0:3.2.7-22.el5 set to be updated
    ---> Package psmisc.x86_64 0:22.2-11 set to be updated
    ---> Package python.x86_64 0:2.4.3-56.el5 set to be updated
    ---> Package python-iniparse.noarch 0:0.2.3-6.el5 set to be updated
    ---> Package python-libs.x86_64 0:2.4.3-56.el5 set to be updated
    ---> Package rpm.x86_64 0:4.4.2.3-31.el5 set to be updated
    ---> Package rpm-libs.x86_64 0:4.4.2.3-31.el5 set to be updated
    ---> Package rpm-python.x86_64 0:4.4.2.3-31.el5 set to be updated
    ---> Package selinux-policy.noarch 0:2.4.6-338.el5 set to be updated
    ---> Package selinux-policy-targeted.noarch 0:2.4.6-338.el5 set to be updated
    ---> Package shadow-utils.x86_64 2:4.0.17-21.el5 set to be updated
    ---> Package sqlite.x86_64 0:3.3.6-6 set to be updated
    ---> Package tcl.x86_64 0:8.4.13-6.el5 set to be updated
    ---> Package tzdata.x86_64 0:2012j-1.el5 set to be updated
    ---> Package udev.x86_64 0:095-14.29.el5 set to be updated
    ---> Package util-linux.x86_64 0:2.13-0.59.el5_8 set to be updated
    ---> Package vim-common.x86_64 2:7.0.109-7.2.el5 set to be updated
    ---> Package vim-enhanced.x86_64 2:7.0.109-7.2.el5 set to be updated
    ---> Package vim-minimal.x86_64 2:7.0.109-7.2.el5 set to be updated
    ---> Package vzctl.x86_64 0:4.1.2-1 set to be updated
    --> Processing Dependency: libcgroup.so.1()(64bit) for package: vzctl
    ---> Package vzctl-core.x86_64 0:4.1.2-1 set to be updated
    ---> Package vzquota.x86_64 0:3.1-1 set to be updated
    ---> Package yum.noarch 0:3.2.22-40.el5.centos set to be updated
    ---> Package yum-metadata-parser.x86_64 0:1.1.2-4.el5 set to be updated
    ---> Package zlib.i386 0:1.2.3-7.el5 set to be updated
    ---> Package zlib.x86_64 0:1.2.3-7.el5 set to be updated
    ---> Package zsh.x86_64 0:4.2.6-8.el5 set to be updated
    --> Running transaction check
    ---> Package apr-util-ldap.x86_64 0:1.4.1-1 set to be updated
    ---> Package e2fsprogs-resize2fs-static.x86_64 0:1.42.3-3.el6.1.ovz set to be updated
    --> Processing Dependency: libc.so.6(GLIBC_2.7)(64bit) for package: e2fsprogs-resize2fs-static
    ---> Package httpd-tools.x86_64 0:2.2.23-3 set to be updated
    ---> Package libcgroup.x86_64 0:0.37-4 set to be updated
    ---> Package libevent.x86_64 0:1.4.13-1 set to be updated
    --> Processing Conflict: ploop-lib conflicts vzkernel < 2.6.32-042stab061.1
    --> Finished Dependency Resolution
    e2fsprogs-resize2fs-static-1.42.3-3.el6.1.ovz.x86_64 from openvz-utils has depsolving problems
      --> Missing Dependency: libc.so.6(GLIBC_2.7)(64bit) is needed by package e2fsprogs-resize2fs-static-1.42.3-3.el6.1.ovz.x86_64 (openvz-utils)
    ploop-lib-1.6-1.x86_64 from openvz-utils has depsolving problems
      --> ploop-lib conflicts with ovzkernel
    Error: Missing Dependency: libc.so.6(GLIBC_2.7)(64bit) is needed by package e2fsprogs-resize2fs-static-1.42.3-3.el6.1.ovz.x86_64 (openvz-utils)
    Error: ploop-lib conflicts with ovzkernel
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    Tell me what to do?
    :confused:
     
  2. Saytik

    Saytik Member

    Joined:
    Jul 2, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    i have the same problem. I have two servers with Centos 5. On both servers the same yum repositories configuration.
    I have updated One server without problems, but on another server i receive error with package e2fsprogs-resize2fs-static-1.42.3-3.el6.1.ovz.x86_64 from openvz-utils

    I don't understand, why yum installs el6 pakackage to Centos 5 ...
     
  3. Saytik

    Saytik Member

    Joined:
    Jul 2, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    resolved.

    Need to remove old ploop and ploop-lib packages:
    rpm -e ploop ploop-lib --nodeps
    then
    yum update

    ;-)
     
  4. faisikhan

    faisikhan Well-Known Member

    Joined:
    Dec 12, 2011
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Islamabad, Pakistan
    cPanel Access Level:
    Root Administrator
    I have also faced such error & the problem was in the repository file CentOS-Base.repo, so I took the backup of it & created a new repo file copying the content from CentOS website & executed the yum update command again and it worked perfectly. After that I was also able to install the other desired packages and dependencies with the help of yum.
     
Loading...

Share This Page