Yum Errors - python3-nftables??

kbisignani

Member
Jan 29, 2012
19
0
51
cPanel Access Level
Root Administrator
Hello all,

Running the latest 102.0.15 on a couple of servers, and both are experiencing the same issue. Started a couple of nights ago where I get an error in my email that the cPanel update process failed. Interestingly enough when I manually ran the cPanel > Upgrade process, it sent me the same error email, but then upgraded my system successfully to 102.0.15 -- so something worked!

Digging a little deeper, this is the error that's coming up (which happens when I run cPanel > Upgrade, Software > System Update, and Software > Updated Server Software):

Problem: package python3-nftables-1:0.9.3-25.el8.x86_64 requires nftables = 1:0.9.3-25.el8, but none of the providers can be installed
- cannot install the best update candidate for package python3-nftables-1:0.9.3-21.el8.x86_64
- package nftables-1:0.9.3-25.el8.i686 is filtered out by exclude filtering
- package nftables-1:0.9.3-25.el8.x86_64 is filtered out by exclude filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


The wording sounds intentional, that nftables is being skipped because "I'm" telling it to be excluded. But when I check the /etc/yum.conf file, I see no reference to nftables in the exclude list.
exclude=bind-chroot dovecot* exim* filesystem nsd* p0f php* proftpd* pure-ftpd*

If I thrown in a command "yum update --nobest" it looks like I can run updates, but it still lists that it's skipping python3-nftables because of broken dependencies. I also get a little concerned SSHing in and doing something like this for fear I'm going to break cPanel (let's just say I suffer from some yum PTSD).

So.... Is this one of those "wait a bit because the cPanel folks need to sort some stuff out because some dependency on the internet broke some other dependency" or is this a true issue? Anyone else running across this or am I just unique?

For completeness, both servers are running on AlmaLinux v8.5.0 STANDARD in vzcontainers.

Thank you to anyone who can shed some light on this!
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,498
1,971
363
cPanel Access Level
Root Administrator
Hey there! I checked a 102.0.15 server on AlmaLinux and I see this:

Code:
# rpm -qa | grep nft
libnftnl-1.1.5-5.el8.x86_64
python3-nftables-0.9.3-25.el8.x86_64
nftables-0.9.3-25.el8.x86_64
so the packages are there by default on that machine.

Here is my /etc/yum.conf file from that system:

Code:
# cat /etc/yum.conf
[main]
exclude=bind-chroot dovecot* exim* filesystem nsd* p0f php* proftpd* pure-ftpd*
tolerant=1
errorlevel=1
plugins=1
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=True
best=True
skip_if_unavailable=False
so I don't see that being excluded.

A forced update is also working well on that machine.

I'm not finding much on my end for that specific error, so it might be best to submit a ticket to our team so we can check your machine's situation directly.
 

kbisignani

Member
Jan 29, 2012
19
0
51
cPanel Access Level
Root Administrator
Thank you for the reply! So I decided to follow your lead, and ran
Code:
# rpm -qa | grep nft
libnftnl-1.1.5-4.el8.x86_64
python3-nftables-0.9.3-21.el8.x86_64
nftables-0.9.3-21.el8.x86_64
I see my nftables are older. So naturally I...
Code:
# yum update nftables
Last metadata expiration check: 4:05:16 ago on Tue May 17 17:53:44 2022.
Dependencies resolved.
Nothing to do.
Complete!
Hmmmm.....
Okay, next try:
Code:
# yum --showduplicates list nftables
Last metadata expiration check: 0:01:11 ago on Tue May 17 22:09:26 2022.
Installed Packages
nftables.x86_64                      1:0.9.3-21.el8                      @System
Also my config file matches yours...

So last thing - am I missing a repo or something?
Code:
# yum repolist
repo id                       repo name
EA4                           EA4 ( EasyApache 4 )
Mysql-connectors-community    MySQL Connectors Community
Mysql-tools-community         MySQL Tools Community
Mysql80-community             MySQL 8.0 Community Server
appstream                     AlmaLinux 8 - AppStream
baseos                        AlmaLinux 8 - BaseOS
cpanel-addons-production-feed cPanel Addons Production Feed
cpanel-plugins                cPanel Plugins project
epel                          Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                  Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                        AlmaLinux 8 - Extras
powertools                    AlmaLinux 8 - PowerTools
psrepo                        Support Repository - x86_64
zabbix                        Zabbix Official Repository - x86_64
zabbix-non-supported          Zabbix Official Repository non-supported - x86_64

Just figured I would see if I can sort this out here before I file a formal ticket.

Oh! And I did try to yum update python3-nftables and it yelled at me telling me there was a broken dependency - couldn't find the matching nftables version it wanted. I know that...