The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yum ... Exim ... and other things that go bump in the night.

Discussion in 'General Discussion' started by asuservice, Jul 16, 2004.

  1. asuservice

    asuservice Well-Known Member

    Oct 24, 2001
    Likes Received:
    Trophy Points:
    Hi Everyone,
    I know there's lots of folks having trouble getting CP installed lately. Typically IF the installation works at all Exim doesn't and so on.

    I just spent the better part of a day figuring out what the hell is going on and getting everything working.

    Here's what I did ... hope it saves some headaches. Oh ... I'm running Fedora Core 1

    1: Modify /etc/yum.conf

    I just copied the default to yum.conf.ORG then I created a new file using the attached text file.

    2: Install cPanel as you always do

    3: Once that's done symlink libdb-4.0 -

    cd /usr/lib
    ln -s

    4: You MIGHT have to turn off iptables to proceed ... service iptables stop

    5: Log into WHM and complete the setup process
    6: Change update preferences to use edge
    7: Update CP to the latest version
    8: Reboot
    9: Change update preferences to use your preferred option
    10: Update CP to the latest version

    This worked for me on two problem boxes.
    Hope someone finds it helps them keep a little more hair on their head.

    Standard Disclaimer: Ues at you're own risk ... your mileage may vary ... don't come looking for me with a shotgun if it doesn't work!!! :-}

    Attached Files:


Share This Page