selberkani

Member
Jan 17, 2013
10
0
1
cPanel Access Level
Root Administrator
Hello,

I have found several possible solutions on cpanel forum but none of them work for me.

1. etc/yum.conf: I commented out the perl*
2. upgraded from RELEASE 11.34.1.7 to EDGE 11.35.0.4
3. yum check-update

Nothing seems to work to let me install OpenCv with yum. What is causing this and how to fix this?

Thanks


[email protected] [~]# yum install opencv-devel
Loaded plugins: fastestmirror
Determining fastest mirrors
* base: mirror.de.leaseweb.net
* epel: mirrors.n-ix.net
* extras: mirror.de.leaseweb.net
* updates: mirror.de.leaseweb.net
base | 3.7 kB 00:00
base/primary_db | 4.5 MB 00:01
epel | 3.7 kB 00:00
epel/primary_db | 3.8 MB 00:00
extras | 3.5 kB 00:00
extras/primary_db | 23 kB 00:00
updates | 3.5 kB 00:00
updates/primary_db | 4.6 MB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package opencv-devel.x86_64 0:2.0.0-9.el6 will be installed
--> Processing Dependency: opencv = 2.0.0-9.el6 for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libml.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libhighgui.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcxcore.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcvaux.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcv.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Running transaction check
---> Package opencv.x86_64 0:2.0.0-9.el6 will be installed
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libunicap.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libucil.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libtheora.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libogg.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libgstreamer-0.10.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libgstbase-0.10.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libdc1394.so.22()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Running transaction check
---> Package gstreamer.x86_64 0:0.10.29-1.el6 will be installed
--> Processing Dependency: gstreamer-tools >= 0.10.29 for package: gstreamer-0.10.29-1.el6.x86_64
---> Package libdc1394.x86_64 0:2.1.2-3.4.el6 will be installed
--> Processing Dependency: libusb-1.0.so.0()(64bit) for package: libdc1394-2.1.2-3.4.el6.x86_64
--> Processing Dependency: libraw1394.so.11()(64bit) for package: libdc1394-2.1.2-3.4.el6.x86_64
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libtheora.x86_64 1:1.1.0-2.el6 will be installed
---> Package libucil.x86_64 0:0.9.10-1.el5 will be installed
---> Package libunicap.x86_64 0:0.9.12-7.el5 will be installed
--> Processing Dependency: libraw1394.so.8()(64bit) for package: libunicap-0.9.12-7.el5.x86_64
---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
--> Running transaction check
---> Package gstreamer-tools.x86_64 0:0.10.29-1.el6 will be installed
---> Package libraw1394.x86_64 0:2.0.4-1.el6 will be installed
---> Package libunicap.x86_64 0:0.9.12-7.el5 will be installed
--> Processing Dependency: libraw1394.so.8()(64bit) for package: libunicap-0.9.12-7.el5.x86_64
---> Package libusb1.x86_64 0:1.0.9-0.5.rc1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: libunicap-0.9.12-7.el5.x86_64 (epel)
Requires: libraw1394.so.8()(64bit)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0


[email protected] [~]# perl -v

This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

Copyright 1987-2009, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl". If you have access to the
Internet, point your browser at The Perl Programming Language - www.perl.org, the Perl Home Page.

[email protected] [~]# uname -r
2.6.32-279.19.1.el6.x86_64

[email protected] [~]# yum check
Loaded plugins: fastestmirror
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
Error: check all

when upgraded to edge these errors were gone:
bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
exim-4.69-30_cpanel_maildir.x86_64 has missing requires of perl(SafeFile)
 

selberkani

Member
Jan 17, 2013
10
0
1
cPanel Access Level
Root Administrator
I would really appreciate it if someone can help me with this. I have found some topics on cpanel were commenting out perl* solves this issue but not for me. I have spent several hours looking for a solution.

I have also installed it trough the whm panel Home »Software »Install an RPM.

RPM Package Installer

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.de.leaseweb.net
* epel: mirrors.n-ix.net
* extras: mirror.de.leaseweb.net
* updates: mirror.de.leaseweb.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package opencv-devel.x86_64 0:2.0.0-9.el6 will be installed
--> Processing Dependency: opencv = 2.0.0-9.el6 for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libml.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libhighgui.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcxcore.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcvaux.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Processing Dependency: libcv.so.2.0()(64bit) for package: opencv-devel-2.0.0-9.el6.x86_64
--> Running transaction check
---> Package opencv.x86_64 0:2.0.0-9.el6 will be installed
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libunicap.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libucil.so.2()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libtheora.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libogg.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libgstreamer-0.10.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libgstbase-0.10.so.0()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Processing Dependency: libdc1394.so.22()(64bit) for package: opencv-2.0.0-9.el6.x86_64
--> Running transaction check
---> Package gstreamer.x86_64 0:0.10.29-1.el6 will be installed
--> Processing Dependency: gstreamer-tools >= 0.10.29 for package: gstreamer-0.10.29-1.el6.x86_64
---> Package libdc1394.x86_64 0:2.1.2-3.4.el6 will be installed
--> Processing Dependency: libusb-1.0.so.0()(64bit) for package: libdc1394-2.1.2-3.4.el6.x86_64
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libtheora.x86_64 1:1.1.0-2.el6 will be installed
---> Package libucil.x86_64 0:0.9.10-1.el5 will be installed
---> Package libunicap.x86_64 0:0.9.12-7.el5 will be installed
--> Processing Dependency: libraw1394.so.8()(64bit) for package: libunicap-0.9.12-7.el5.x86_64
---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
--> Running transaction check
---> Package gstreamer-tools.x86_64 0:0.10.29-1.el6 will be installed
---> Package libunicap.x86_64 0:0.9.12-7.el5 will be installed
--> Processing Dependency: libraw1394.so.8()(64bit) for package: libunicap-0.9.12-7.el5.x86_64
---> Package libusb1.x86_64 0:1.0.9-0.5.rc1.el6 will be installed
--> Finished Dependency Resolution
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
Install complete
 
Last edited: