The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yum not finding kernel updates

Discussion in 'General Discussion' started by ghstber, Sep 5, 2006.

  1. ghstber

    ghstber Member

    Joined:
    Oct 7, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Greetings!

    I am trying to update the kernels on a few servers, and I get the following:

    -----------

    root@server1 [~]# yum update
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No Packages Available for Update
    No actions to take

    root@server2 [~]# yum update
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No Packages Available for Update
    No actions to take

    ------------

    However, the kernel versions are not up to date (2.4.21-47.ELsmp is the version I believe that I'm looking for, the first is running 2.4.21-27.0.2.ELsmp and the second 2.4.21-32.ELsmp). I have already removed the kernel* from /etc/yum.conf.

    Also, I noticed that on these servers, there is no /etc/yum.repos.d, instead all of the settings are listed in /etc/yum.conf. Is this normal, and is there any benefit to either way? How would I change this setup, if I wanted.

    Thanks in advance!
     
    #1 ghstber, Sep 5, 2006
    Last edited: Sep 7, 2006
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    There won't be a /etc/yum.repos.d as you're using CentOSv3 - that came in for CentOSv4.

    You need to edit /etc/yum.conf and remove kernel* from the exclude= line and then run:

    yum update

    Once it is done, add back kernel* to the exclude= line in yum.conf

    Then reboot and cross your fingers ;)
     
  3. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    What is odd is that the first server (Kernel version 2.4.21-27.0.2.ELsmp) is reporting that the OS is Centos and the kernels are Fedora.

    root@XXXX [~]# cat /etc/*release*
    CentOS release 3.8 (Final)


    root@XXXX [~]# pico /etc/grub.conf
    title Fedora Core (2.4.21-27.0.2.ELsmp)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-27.0.2.ELsmp ro root=LABEL=/
    initrd /initrd-2.4.21-27.0.2.ELsmp.img

    Anyone seen this before?

    Obviously an OS reload will resolve, but that is a last resort.

    P.S. Ghstber and I are co-workers, this is the same issue.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That was probably just what someone configured when editing grub.conf - no need for an OS reload. You do need to upgrade that kernel to the latest CentOS v3 one, though, as it's insecure.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you checked that yum.conf doesn't have kernel* in the exclude= list? You might also need to check in the repo file incase it has been put in there directly too.
     
  6. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    Thanks Chirpy. Yeah that's what we're working on. Unfortunately, yum isn't recognizing any newer kernels and I'm a little apprehensive to do a manual upgrade. I thought the grub.conf settings may be related to why yum isn't seeing an update.

    However, yum does appear to be using the correct CentOS mirrors for updating so I'm a little stumped.
     
  7. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    Also, kernel* is removed from yum.conf exclude= list. This is CentOS 3 so, as you noted, the repo file is not in use (correct?). I don't see anything explicitly excluding the kernel update.
     
Loading...

Share This Page