The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yum update error

Discussion in 'EasyApache' started by Nirjonadda, May 27, 2017.

Tags:
  1. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    341
    Likes Received:
    8
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    I am getting error from yum update, Please let me know this fix.

    Code:
    [root@na ~]# yum update
    Loaded plugins: fastestmirror, tsflags, universal-hooks
    Loading mirror speeds from cached hostfile
     * EA4: 85.13.201.2
     * EA4-experimental: 85.13.201.2
     * cpanel-addons-production-feed: 85.13.201.2
     * base: centos.mirror.triple-it.nl
     * epel: mirrors.coreix.net
     * extras: centos.mirror.triple-it.nl
     * updates: centos.mirror.triple-it.nl
    Resolving Dependencies
    --> Running transaction check
    ---> Package NetworkManager.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-adsl.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-adsl.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-bluetooth.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-bluetooth.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-glib.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-glib.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-libnm.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-libnm.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-team.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-team.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-tui.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-tui.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-wifi.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-wifi.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package NetworkManager-wwan.x86_64 1:1.4.0-19.el7_3 will be updated
    ---> Package NetworkManager-wwan.x86_64 1:1.4.0-20.el7_3 will be an update
    ---> Package dracut.x86_64 0:033-463.el7 will be updated
    ---> Package dracut.x86_64 0:033-463.el7_3.1 will be an update
    ---> Package dracut-config-rescue.x86_64 0:033-463.el7 will be updated
    ---> Package dracut-config-rescue.x86_64 0:033-463.el7_3.1 will be an update
    ---> Package dracut-network.x86_64 0:033-463.el7 will be updated
    ---> Package dracut-network.x86_64 0:033-463.el7_3.1 will be an update
    ---> Package firewalld.noarch 0:0.4.3.2-8.1.el7_3.2 will be updated
    ---> Package firewalld.noarch 0:0.4.3.2-8.1.el7_3.3 will be an update
    ---> Package firewalld-filesystem.noarch 0:0.4.3.2-8.1.el7_3.2 will be updated
    ---> Package firewalld-filesystem.noarch 0:0.4.3.2-8.1.el7_3.3 will be an update
    ---> Package glibc.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package glibc.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package glibc-common.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package glibc-common.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package glibc-devel.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package glibc-devel.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package glibc-headers.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package glibc-headers.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package glibc-static.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package glibc-static.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.131-2.b11.el7_3 will be updated
    ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.131-3.b12.el7_3 will be an update
    ---> Package java-1.8.0-openjdk-devel.x86_64 1:1.8.0.131-2.b11.el7_3 will be updated
    ---> Package java-1.8.0-openjdk-devel.x86_64 1:1.8.0.131-3.b12.el7_3 will be an update
    ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.131-2.b11.el7_3 will be updated
    ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.131-3.b12.el7_3 will be an update
    ---> Package kernel.x86_64 0:3.10.0-514.21.1.el7 will be installed
    ---> Package kernel-devel.x86_64 0:3.10.0-514.21.1.el7 will be installed
    ---> Package kernel-headers.x86_64 0:3.10.0-514.16.1.el7 will be updated
    ---> Package kernel-headers.x86_64 0:3.10.0-514.21.1.el7 will be an update
    ---> Package kernel-tools.x86_64 0:3.10.0-514.16.1.el7 will be updated
    ---> Package kernel-tools.x86_64 0:3.10.0-514.21.1.el7 will be an update
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-514.16.1.el7 will be updated
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-514.21.1.el7 will be an update
    ---> Package kpartx.x86_64 0:0.4.9-99.el7_3.1 will be updated
    ---> Package kpartx.x86_64 0:0.4.9-99.el7_3.3 will be an update
    ---> Package libgudev1.x86_64 0:219-30.el7_3.8 will be updated
    ---> Package libgudev1.x86_64 0:219-30.el7_3.9 will be an update
    ---> Package libnetfilter_conntrack.x86_64 0:1.0.4-2.el7 will be updated
    ---> Package libnetfilter_conntrack.x86_64 0:1.0.6-1.el7_3 will be an update
    ---> Package nscd.x86_64 0:2.17-157.el7_3.1 will be updated
    ---> Package nscd.x86_64 0:2.17-157.el7_3.2 will be an update
    ---> Package polkit.x86_64 0:0.112-11.el7_3 will be updated
    ---> Package polkit.x86_64 0:0.112-12.el7_3 will be an update
    ---> Package python-firewall.noarch 0:0.4.3.2-8.1.el7_3.2 will be updated
    ---> Package python-firewall.noarch 0:0.4.3.2-8.1.el7_3.3 will be an update
    ---> Package python-perf.x86_64 0:3.10.0-514.16.1.el7 will be updated
    ---> Package python-perf.x86_64 0:3.10.0-514.21.1.el7 will be an update
    ---> Package systemd.x86_64 0:219-30.el7_3.8 will be updated
    ---> Package systemd.x86_64 0:219-30.el7_3.9 will be an update
    ---> Package systemd-libs.x86_64 0:219-30.el7_3.8 will be updated
    ---> Package systemd-libs.x86_64 0:219-30.el7_3.9 will be an update
    ---> Package systemd-python.x86_64 0:219-30.el7_3.8 will be updated
    ---> Package systemd-python.x86_64 0:219-30.el7_3.9 will be an update
    ---> Package systemd-sysv.x86_64 0:219-30.el7_3.8 will be updated
    ---> Package systemd-sysv.x86_64 0:219-30.el7_3.9 will be an update
    ---> Package tuned.noarch 0:2.7.1-3.el7_3.1 will be updated
    ---> Package tuned.noarch 0:2.7.1-3.el7_3.2 will be an update
    --> Processing Dependency: /usr/sbin/ldconfig for package: libva1-1.3.1-11.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libmp3lame0-3.99.3-23.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libavcodec55-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libavdevice55-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: librtmp0-2.3-1.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libopencore-amrnb0-0.1.3-1.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libxavs1-0.1.51-2.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libopencore-amrwb0-0.1.3-1.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libavutil52-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libx264_142-0.142-20_20140406.2245.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: 1:libfaad2-2.7-18.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libavfilter4-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libswresample0-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libswscale2-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libpostproc52-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libavformat55-2.2.1-65.el7.x86_64
    --> Processing Dependency: /usr/sbin/ldconfig for package: libxvidcore4-1.3.2-15.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: libva1-1.3.1-11.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libxavs1-0.1.51-2.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: librtmp0-2.3-1.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libswresample0-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libmp3lame0-3.99.3-23.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: 1:libfaad2-2.7-18.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libxvidcore4-1.3.2-15.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libavformat55-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libavdevice55-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libx264_142-0.142-20_20140406.2245.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libopencore-amrnb0-0.1.3-1.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libavutil52-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libavfilter4-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libswscale2-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libpostproc52-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libavcodec55-2.2.1-65.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
    Error: Package: libopencore-amrwb0-0.1.3-1.el7.x86_64 (@atrpms)
               Requires: /usr/sbin/ldconfig
               Removing: glibc-2.17-157.el7_3.1.x86_64 (@updates)
                   Not found
               Updated By: glibc-2.17-157.el7_3.2.x86_64 (updates)
                   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    [root@na ~]#
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,037
    Likes Received:
    1,278
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like your system package manager (YUM) is configured to use a third-party repository (ATRPMS). Are you using this REPO for a specific purpose? If not, you may want to consider removing this REPO from your /etc/yum.repos.d/ directory and reverting to the default REPO files that come with CentOS.

    Thank you.
     
  3. Nirjonadda

    Nirjonadda Well-Known Member

    Joined:
    May 8, 2013
    Messages:
    341
    Likes Received:
    8
    Trophy Points:
    18
    cPanel Access Level:
    Website Owner
    I am no more using ATRPMS repository but we have removed some Package from ATRPMS repository then yum update are work.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,037
    Likes Received:
    1,278
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you confirm if the issue persists after removing the REPO?

    Thank you.
     
Loading...

Share This Page