Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

yum update error

Discussion in 'General Discussion' started by mahdy_sharifi, Mar 21, 2018.

Tags:
  1. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    when I update system with Yum I get following error :

    Code:
    yum update
    sh: line 0: cd: /usr/share/rhn/up2date_client/: No such file or directory
    Plugin "rhnplugin" can't be imported
    Loaded plugins: fastestmirror, langpacks, universal-hooks
    Loading mirror speeds from cached hostfile
     * cpanel-addons-production-feed: 85.13.201.2
     * base: ftp.fau.de
     * epel: epel.mirror.wearetriple.com
     * extras: ftp.fau.de
     * updates: ftp.fau.de
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_fcgid.x86_64 0:2.3.9-4.el7 will be updated
    ---> Package mod_fcgid.x86_64 0:2.3.9-4.el7_4.1 will be an update
    --> Processing Dependency: httpd-mmn = 20120211x8664 for package: mod_fcgid-2.3.9-4.el7_4.1.x86_64
    --> Finished Dependency Resolution
    Error: Package: mod_fcgid-2.3.9-4.el7_4.1.x86_64 (updates)
               Requires: httpd-mmn = 20120211x8664
     You could try using --skip-broken to work around the problem
    How can resolve ?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This isn't an RPM that cPanel provides. The FCGId RPM that's provided with EasyApache 4 is named "ea-apache24-mod_fcgid" as opposed to "mod_fcgid". You can check to see which YUM repo your system is using to fetch the mod_fcgid RPM with a command like this:

    Code:
    yum info mod_fcgid
    Look for "From repo" in the output, as that's likely the third-party YUM Repo you are using that's not compatible with EasyApache 4.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mahdy_sharifi

    mahdy_sharifi Well-Known Member

    Joined:
    Feb 26, 2012
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    Code:
    Installed Packages
    Name        : mod_fcgid
    Arch        : x86_64
    Version     : 2.3.9
    Release     : 4.el7
    Size        : 228 k
    Repo        : installed
    From repo   : base
    Summary     : FastCGI interface module for Apache 2
    URL         : http://httpd.apache.org/mod_fcgid/
    License     : ASL 2.0
    Description : mod_fcgid is a binary-compatible alternative to the Apache module mod_fastcgi.
                : mod_fcgid has a new process management strategy, which concentrates on reducing
                : the number of fastcgi servers, and kicking out corrupt fastcgi servers as soon
                : as possible.
    
    Available Packages
    Name        : mod_fcgid
    Arch        : x86_64
    Version     : 2.3.9
    Release     : 4.el7_4.1
    Size        : 79 k
    Repo        : updates/7/x86_64
    Summary     : FastCGI interface module for Apache 2
    URL         : http://httpd.apache.org/mod_fcgid/
    License     : ASL 2.0
    Description : mod_fcgid is a binary-compatible alternative to the Apache module mod_fastcgi.
                : mod_fcgid has a new process management strategy, which concentrates on reducing
                : the number of fastcgi servers, and kicking out corrupt fastcgi servers as soon
                : as possible.

    I can see this package with this detail on all our server that running EA4
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    That package is not installed by default in CentOS. It would have had to have been installed manually at some point. You'll need to remove that package as it's unsupported and not intended to function with EasyApache 4. EasyApache 4 offers it's own RPMs and thus doesn't use the same RPMs offered by CentOS.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice