Festuc

Registered
Jul 26, 2021
2
0
1
Spain
cPanel Access Level
Root Administrator
Hello,

Trying to do a yum update I get the following errors; it was working two days ago.

Cloudlinux + Cpanel + LiteSpeed

Code:
[[email protected]***** ~]# yum update
This system is receiving updates from CloudLinux Network server.
Última comprobación de caducidad de metadatos hecha hace 1:03:47, el lun 26 jul 2021 10:39:16 CEST.
Error:
Problema 1: package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.15-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.16-1.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.21-2.el8.x86_64 and alt-php-internal-cli-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.19-2.el8.x86_64 and alt-php-internal-cli-7.4.21-2.el8.x86_64
  - cannot install the best update candidate for package alt-php-internal-common-7.4.19-2.el8.x86_64
  - cannot install the best update candidate for package alt-php-internal-cli-7.4.19-2.el8.x86_64
  - cannot install the best update candidate for package ai-bolit-1:30.7.3-1.el8.x86_64
Problema 2: package imunify-antivirus-5.7.4-4.noarch requires ai-bolit >= 1:30.7.3-1, but none of the providers can be installed
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.21-2.el8.x86_64 and alt-php-internal-cli-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.19-2.el8.x86_64 and alt-php-internal-cli-7.4.21-2.el8.x86_64
  - package alt-php-internal-common-7.4.15-3.el8.x86_64 requires alt-php-internal = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-common-7.4.16-1.el8.x86_64 requires alt-php-internal = 7.4.16-1.el8, but none of the providers can be installed
  - package alt-php-internal-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - package alt-php-internal-7.4.21-2.el8.x86_64 requires alt-php-internal-cli = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-7.4.15-3.el8.x86_64 and alt-php-internal-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-7.4.16-1.el8.x86_64 and alt-php-internal-7.4.21-2.el8.x86_64
  - cannot install the best update candidate for package imunify-antivirus-5.7.4-4.noarch
  - cannot install the best update candidate for package alt-php-internal-7.4.19-2.el8.x86_64
Problema 3: problem with installed package ai-bolit-1:30.7.3-1.el8.x86_64
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-cli-7.4.19-2.el8.x86_64 requires alt-php-internal-common = 7.4.19-2.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.21-2.el8.x86_64 and alt-php-internal-common-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.15-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.19-2.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.16-1.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - package alt-php-internal-intl-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package alt-php-internal-intl-7.4.19-2.el8.x86_64
Problema 4: package imunify-antivirus-cpanel-5.7.4-4.noarch requires imunify-antivirus = 5.7.4-4, but none of the providers can be installed
  - package imunify-antivirus-5.7.4-4.noarch requires ai-bolit >= 1:30.7.3-1, but none of the providers can be installed
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-cli-7.4.19-2.el8.x86_64 requires alt-php-internal-common = 7.4.19-2.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.21-2.el8.x86_64 and alt-php-internal-common-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.15-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.19-2.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.16-1.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - package alt-php-internal-mbstring-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package imunify-antivirus-cpanel-5.7.4-4.noarch
  - cannot install the best update candidate for package alt-php-internal-mbstring-7.4.19-2.el8.x86_64
Problema 5: problem with installed package imunify-antivirus-5.7.4-4.noarch
  - package imunify-antivirus-5.7.4-4.noarch requires ai-bolit >= 1:30.7.3-1, but none of the providers can be installed
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-cli-7.4.19-2.el8.x86_64 requires alt-php-internal-common = 7.4.19-2.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.21-2.el8.x86_64 and alt-php-internal-common-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.15-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.19-2.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.16-1.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - package alt-php-internal-mysqlnd-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package alt-php-internal-mysqlnd-7.4.19-2.el8.x86_64
Problema 6: problem with installed package imunify-antivirus-cpanel-5.7.4-4.noarch
  - package imunify-antivirus-cpanel-5.7.4-4.noarch requires imunify-antivirus = 5.7.4-4, but none of the providers can be installed
  - package imunify-antivirus-5.7.4-4.noarch requires ai-bolit >= 1:30.7.3-1, but none of the providers can be installed
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-cli-7.4.19-2.el8.x86_64 requires alt-php-internal-common = 7.4.19-2.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.21-2.el8.x86_64 and alt-php-internal-common-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.15-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.19-2.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-common-7.4.16-1.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - package alt-php-internal-pdo-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package alt-php-internal-pdo-7.4.19-2.el8.x86_64
(pruebe a añadir '--allowerasing' a la línea de comandos para reemplazar los paquetes que producen conflictos o '--skip-broken' para descartar los paquetes que no se pueden instalar o '--nobest' para no tener en cuenta sólo los mejores candidatos)
[[email protected]***** ~]#
If I force with allow erasing:

Code:
[[email protected]***** ~]# yum update --allowerasing
This system is receiving updates from CloudLinux Network server.
Última comprobación de caducidad de metadatos hecha hace 1:13:11, el lun 26 jul 2021 10:39:16 CEST.
Error:
Problema: cannot install the best update candidate for package ai-bolit-1:30.7.3-1.el8.x86_64
  - problem with installed package ai-bolit-1:30.7.3-1.el8.x86_64
  - package alt-php-internal-sqlite3-7.4.12-3.el8.x86_64 requires alt-php-internal-common = 7.4.12-3.el8, but none of the providers can be installed
  - package ai-bolit-1:30.7.3-1.el8.x86_64 requires alt-php-internal-sqlite3, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.15-3.el8.x86_64 requires alt-php-internal-common = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-sqlite3-7.4.16-1.el8.x86_64 requires alt-php-internal-common = 7.4.16-1.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-common-7.4.12-3.el8.x86_64 and alt-php-internal-common-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.21-2.el8.x86_64 and alt-php-internal-cli-7.4.19-2.el8.x86_64
  - cannot install both alt-php-internal-cli-7.4.19-2.el8.x86_64 and alt-php-internal-cli-7.4.21-2.el8.x86_64
  - package alt-php-internal-common-7.4.15-3.el8.x86_64 requires alt-php-internal = 7.4.15-3.el8, but none of the providers can be installed
  - package alt-php-internal-common-7.4.16-1.el8.x86_64 requires alt-php-internal = 7.4.16-1.el8, but none of the providers can be installed
  - package alt-php-internal-7.4.21-2.el8.x86_64 requires alt-php-internal-common = 7.4.21-2.el8, but none of the providers can be installed
  - package alt-php-internal-7.4.21-2.el8.x86_64 requires alt-php-internal-cli = 7.4.21-2.el8, but none of the providers can be installed
  - cannot install both alt-php-internal-7.4.15-3.el8.x86_64 and alt-php-internal-7.4.21-2.el8.x86_64
  - cannot install both alt-php-internal-7.4.16-1.el8.x86_64 and alt-php-internal-7.4.21-2.el8.x86_64
  - problem with installed package alt-php-internal-7.4.19-2.el8.x86_64
  - cannot install the best update candidate for package alt-php-internal-7.4.19-2.el8.x86_64
(pruebe a añadir '--skip-broken' para descartar los paquetes que no se pueden instalar o '--nobest' para no tener en cuenta sólo los mejores candidatos)
[[email protected]***** ~]#
Any idea on how to solve that?

Thanks!
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,923
912
313
cPanel Access Level
Root Administrator
Hey there! It sounds like there is an issue with either the CloudLinux license or the repositories on the machine. If your CloudLinux license is purchased through cPanel it would be best to contact our support team so we can take a look at the system for you. If the license is purchased from CloudLinux, I'd contact them directly about this so they can check those issues.
 
  • Like
Reactions: Festuc

Festuc

Registered
Jul 26, 2021
2
0
1
Spain
cPanel Access Level
Root Administrator
Hey there! It sounds like there is an issue with either the CloudLinux license or the repositories on the machine. If your CloudLinux license is purchased through cPanel it would be best to contact our support team so we can take a look at the system for you. If the license is purchased from CloudLinux, I'd contact them directly about this so they can check those issues.
Thanks it suddently started working again.

Regards.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,923
912
313
cPanel Access Level
Root Administrator
That's interesting - that would most likely indicate a networking issue between your machine and the CloudLinux network, although I haven't heard of any outages on the CloudLinux side of things today. I'm glad to hear it's working now though!