The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yum Update Failing!

Discussion in 'General Discussion' started by DReade83, Jul 15, 2007.

  1. DReade83

    DReade83 Well-Known Member

    Joined:
    Oct 20, 2006
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cheshire, UK
    I'm running the following on my server:
    Linux <Server Hostname> 2.6.16-xen3_86.1_fc4 #1 SMP Thu Apr 13 08:26:52 PDT 2006 i686 i686 i386 GNU/Linux

    But when I try to run a yum update, the following happens:

    Code:
    root@websvr1 [~]# yum update
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for kernel to pack into transaction set.
    kernel-2.6.9-55.0.2.EL.i6 100% |=========================| 237 kB    00:00
    ---> Package kernel.i686 0:2.6.9-55.0.2.EL set to be installed
    ---> Downloading header for kernel-smp to pack into transaction set.
    kernel-smp-2.6.9-55.0.2.E 100% |=========================| 238 kB    00:00
    ---> Package kernel-smp.i686 0:2.6.9-55.0.2.EL set to be installed
    --> Running transaction check
    
    Dependencies Resolved
    
    =============================================================================
     Package                 Arch       Version          Repository        Size
    =============================================================================
    Installing:
     kernel                  i686       2.6.9-55.0.2.EL  update             11 M
     kernel-smp              i686       2.6.9-55.0.2.EL  update             11 M
    
    Transaction Summary
    =============================================================================
    Install      2 Package(s)
    Update       0 Package(s)
    Remove       0 Package(s)
    Total download size: 22 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/2): kernel-2.6.9-55.0. 100% |=========================|  11 MB    00:15
    (2/2): kernel-smp-2.6.9-5 100% |=========================|  11 MB    00:13
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing: kernel-smp                   ######################### [1/2]
    grubby fatal error: unable to find a suitable template
      Installing: kernel                       ######################### [2/2]
    grubby fatal error: unable to find a suitable template
    
    Installed: kernel.i686 0:2.6.9-55.0.2.EL kernel-smp.i686 0:2.6.9-55.0.2.EL
    Complete!
    root@websvr1 [~]#
    Any idea how I can go about fixing this?
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    According to the first line of your post above, you are trying to install the wrong kernel files ...
    Code:
    yum update kernel-xen*
    
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're running a Xen kernel it would suggest that you have a virtual server, not a real one, in which case you should not upgrade the kernel yourself - that's usually the job of the server provider.
     
Loading...

Share This Page