xabungo

Member
Nov 10, 2006
11
0
151
Sorry to reopen this but my cpanel update continues with same error.
Code:
[2017-02-13 01:09:15 -0200] E (XID jqqymy) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 2028) reported error number 1 when it ended. : Error: Package: redhat-rpm-config-9.1.0-72.el7.centos.noarch (base)
[2017-02-13 01:09:15 -0200] Requires: perl-srpm-macros
[2017-02-13 01:09:15 -0200] checkyum version 22.3
[2017-02-13 01:09:18 -0200] E Sysup: Needed system RPMs were not installed: redhat-rpm-config
[2017-02-13 01:09:18 -0200] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2017-02-13 01:09:18 -0200] The Administrator will be notified to review this output when this script completes
=> Log closed Mon Feb 13 01:09:18 2017

 and here the error from the cpanel
[2017-02-14 16:14:23 -0200] E (XID yhahuy) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 24355) reported error number 1 when it ended. : Error: Package: redhat-rpm-config-9.1.0-72.el7.centos.noarch (base)
[2017-02-14 16:14:23 -0200]            Requires: perl-srpm-macros
[2017-02-14 16:14:23 -0200]   checkyum version 22.3
[2017-02-14 16:14:25 -0200] E Sysup: Needed system RPMs were not installed: redhat-rpm-config
[2017-02-14 16:14:25 -0200] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2017-02-14 16:14:25 -0200]   The Administrator will be notified to review this output when this script completes
=> Log closed Tue Feb 14 16:14:25 2017
[2017-02-14 16:14:25 -0200] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1487096049.log` failed, exited with code 18 (signal = 0)
I couldn't find a way to solve.
Thank you!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
[2017-02-14 16:14:23 -0200] E (XID yhahuy) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 24355) reported error number 1 when it ended. : Error: Package: redhat-rpm-config-9.1.0-72.el7.centos.noarch (base) [2017-02-14 16:14:23 -0200] Requires: perl-srpm-macros
Hello,

This problem relates to your system package manager (YUM) as opposed to the cPanel software. Please run the following commands and let us know the output:

Code:
cat /etc/redhat-release
grep exclude /etc/yum.conf
Thank you.