Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Yum update Python Memory Error

Discussion in 'General Discussion' started by Mauro de Palma, Aug 23, 2017.

  1. Mauro de Palma

    Mauro de Palma Registered

    May 5, 2017
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hi i'm getting this error while executing "yum update"

    ec2-user@indalaterre [~]# sudo yum update
    Loaded plugins: priorities, universal-hooks, update-motd, upgrade-helper
    EA4                                                                                           | 3.0 kB  00:00:00
    cpanel-addons-production-feed                                                                 | 2.9 kB  00:00:00
    MariaDB100                                                                                    | 2.9 kB  00:00:00
    amzn-main                                                                                     | 2.1 kB  00:00:00
    amzn-updates                                                                                  | 2.3 kB  00:00:00
    cpanel-plugins                                                                                | 2.9 kB  00:00:00
    (1/4): cpanel-addons-production-feed/x86_64/primary_db                                        | 9.4 kB  00:00:00
    (2/4): MariaDB100/primary_db                                                                  |  22 kB  00:00:00
    (3/4): cpanel-plugins/primary_db                                                              |  37 kB  00:00:00
    (4/4): EA4/x86_64/primary_db                                                                  |  31 MB  00:00:02
    (1/5): amzn-main/latest/group                                                                 |  35 kB  00:00:00
    (2/5): amzn-updates/latest/group                                                              |  35 kB  00:00:00
    (3/5): amzn-updates/latest/updateinfo                                                         | 407 kB  00:00:00
    (4/5): amzn-updates/latest/primary_db                                                         | 552 kB  00:00:00
    (5/5): amzn-main/latest/primary_db                                                            | 3.6 MB  00:00:00
    Traceback (most recent call last):
      File "/usr/bin/yum", line 29, in <module>
        yummain.user_main(sys.argv[1:], exit_code=True)
      File "/usr/share/yum-cli/", line 365, in user_main
        errcode = main(args)
      File "/usr/share/yum-cli/", line 174, in main
        result, resultmsgs = base.doCommands()
      File "/usr/share/yum-cli/", line 574, in doCommands
        return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
      File "/usr/share/yum-cli/", line 496, in doCommand
        ret = base.updatePkgs(extcmds, update_to=(basecmd == 'update-to'))
      File "/usr/share/yum-cli/", line 1026, in updatePkgs
      File "/usr/lib/python2.7/dist-packages/yum/", line 5107, in update
        updates = self.up.getUpdatesTuples()
      File "/usr/lib/python2.7/dist-packages/yum/", line 1091, in <lambda>
        up = property(fget=lambda self: self._getUpdates(),
      File "/usr/lib/python2.7/dist-packages/yum/", line 836, in _getUpdates
        self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
      File "/usr/lib/python2.7/dist-packages/yum/", line 1072, in <lambda>
        pkgSack = property(fget=lambda self: self._getSacks(),
      File "/usr/lib/python2.7/dist-packages/yum/", line 790, in _getSacks'exclude')
      File "/usr/lib/python2.7/dist-packages/yum/", line 188, in run
        func(conduitcls(self, self.base, conf, **kwargs))
      File "/usr/lib/yum-plugins/", line 129, in exclude_hook
        repopkgs_archless = _pkglist_to_dict(conduit.getPackages(repo), repo.priority)
      File "/usr/lib/python2.7/dist-packages/yum/", line 688, in getPackages
        return self._base.pkgSack.returnPackages(arg)
      File "/usr/lib/python2.7/dist-packages/yum/", line 495, in returnPackages
      File "/usr/lib/python2.7/dist-packages/yum/", line 1651, in returnPackages
        pkgobjlist = self._buildPkgObjList(repoid, patterns, ignore_case)
      File "/usr/lib/python2.7/dist-packages/yum/", line 46, in newFunc
        return func(*args, **kwargs)
      File "/usr/lib/python2.7/dist-packages/yum/", line 1615, in _buildPkgObjList
        po = self._packageByKeyData(repo, x['pkgKey'], x)
      File "/usr/lib/python2.7/dist-packages/yum/", line 753, in _packageByKeyData
        if exclude and self._pkgExcludedRKD(repo, pkgKey, data):
      File "/usr/lib/python2.7/dist-packages/yum/", line 673, in _pkgExcludedRKD
        return self._pkgExcludedRKNEVRA(repo, pkgKey, n,e,v,r,a)
      File "/usr/lib/python2.7/dist-packages/yum/", line 636, in _pkgExcludedRKNEVRA
        if _excluder_match(exM, match, regexp_match, data, e,v,r,a):
      File "/usr/lib/python2.7/dist-packages/yum/", line 112, in _excluder_match
        if _parse_pkg(match, regexp_match, data, e,v,r,a):
      File "/usr/lib/python2.7/dist-packages/yum/", line 105, in _parse_pkg
        if regexp_match(item):
    Error in atexit._run_exitfuncs:
    Traceback (most recent call last):
      File "/usr/lib64/python2.7/", line 24, in _run_exitfuncs
        func(*targs, **kargs)
      File "/usr/lib/python2.7/dist-packages/yum/", line 180, in run
    Error in sys.exitfunc:
    Traceback (most recent call last):
      File "/usr/lib64/python2.7/", line 24, in _run_exitfuncs
        func(*targs, **kargs)
      File "/usr/lib/python2.7/dist-packages/yum/", line 180, in run
        conduitcls = eval(conduitcls)       # Convert name to class object
    I tried to clean up with "yum clean all" but the error is still the same.
    The cpanel version is the 66.0.14, OS CentOS 6
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    This can happen if your server is running out of available memory. Check to see if the server is reaching it's memory limit by using the "free -m" command when YUM updates. Also, if this is a VPS, ensure the server is not reaching any VPS resource limits.

    Thank you.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice